How to set firmware version in Particle Dev?

Hello,

The web builder has a selector for the firmware version to use. I am not able to find the same in the Particle Dev.
Is that even implemented?

Markus

That is, unfortunately, not in there yet.

But if you want local building without local toolchain against other firmware, you can use CLI

particle compile photon . firmware.bin --target vesionNumber
2 Likes

Can you clarify that please.
If I flash using ‘BUILD’ I get the firmware version as selected.
If I flash with ‘DEV’ the firmware does not get updated.

Is that correct?

What do you mean?
Dev always builds against the Default version (as noted in Build - but without any means to select any other) and if your device is not compatible with that your device will go into Safe Mode on reboot - just the same as with Build.
If it’s a WiFi device it should get an OTA system update via Safe Mode Healer (independent of dev environment) and if it’s an Electron you won’t get an OTA system update via build either.

Let me be clearer.
If I compile and flash with 'Build ’ I get the option to select the runtime Firmware version that it builds with.
I assume that it either always loads the runtime firmware when flashed, or loads it if it what has been selected differs from the currently flashed version.

If I build with DEV, there is no option to select the runtime version, so as you say I now know it builds with the Default version…

Could you verify or correct those statements please.

Then, assuming I only use DEV, for months on end - and the default firmware changes ( I guess I would only know this if I logged on with BUILD), then it is possible to be sending DEV compiled code to devices in the field that have had worked on an older runtime version but may not work with the freshly compiled code if compiled against a newer runtime.

I haven’t looked at this OTA healer you mention - but I’m guessing this trys to resolve this?
FYI, I’m back working on Photon 6 to 8 months or more since last used and have been strugling to get existing code to run properly with new photons.

System firmware with a equal or higher version number than your selected application target will stay on your Photon/Electron since they are backwards compatible.
When the system version is less than what you selected the above said applies - Safe Mode Healer :wink:
For Cores the system and application firmware are one monolithic binary so the version will always be the same.

There’ll always be an anouncement on here when there is a new releae or you could look here

It’susually good in doing this.

More info about your code and issues would maybe help.

So this still is not possible? to set firmware version in Particle Dev? I have been having problem updating my electron from 0.5.2 to 0.5.3 and it seems like the Particle Dev is compiling for firmware 0.5.3 so it is not working for my Electron… off course my main issue is the problem with updating the electron but it would have been nice to be able to set the firmware version in Particle Dev…

What’s the problem with updating the system?
What have you tried and how does it fail?
You can’t select the target version with Dev, but you can with CLI.

what I have tried with updating is use the CLI by entering “particle update” it seems to do someting (takes some seconds) but there is still the same 0.5.2 firmware on the electron after that “update” I have also tried the Particle Firmware Manager, several times, in most cases noting happends but some times it loads until the magenta color is at the “g” in the word “Updating” then there comes a sound from the computer (the sound when you plug and unplug the USB) and then it ends by giving me the “Aw, something went wrong” … but just now, while writing this I dried one more time (approxm for the 10-15th time) including some of the tries with different usb cable and different electron and now all out of sudden it worked, using the Particle Firmware Manager! and now I have 0.5.3 :slight_smile:

1 Like

Well now I am trying to update my second electron (I have 4 units) and it is only giving me Aw, something bad happened, and no progress in the progress bar… don’t know why all out of sudden it worked for the other electron yesterday… has no one else been having problem with this… If I try the CLI and enter partucle update that will not update anything, still 0.5.2 after that update…
Edit: and now I tried a fresh one out of the box with FW 0.4.8 on it, and that one did update without any trouble, so it seems only to be problem to update from 0.5.2 to 0.5.3

What version CLI have you got installed?

particle --version

But since I also have multiple Electrons, I usually download the system firmware binaries and then flash like this

particle flash --usb system_firmware_part1.bin
particle flash --usb system_firmware_part2.bin
# if you get a three part system also:
# particle flash --usb system_firmware_part3.bin
particle flash --usb tinker

I have version 1.15.0

Current public version is 1.17.0
When you haven’t updated for a while it’s always good to do when you experience unexpected behaviour

npm update -g particle-cli

thanks for pointing that out!! :slight_smile: I just updated the CLI to 1.17.0 and than ran particle update and then my electron updated to 0.5.3, thanks alot ScruffR

1 Like