How to OTA flash 0.7.0 system firmare on deployed photons


#1

Hello,

I searched the forum and Github, but didnt find satisfactory answer… What is the right process to OTA flash 0.7.0 firmware on deployed Photons running mostly 0.6.x?

I tried flashing first part1, then part2, then bootloader. After this process, the device then works normally, but CLI reports old version (0.6.2) while System.versionNumber() gives some nonsense numbers like 12.0.2. Tried the same process twice with just the nonsense number changing.

We are running local cloud (Brewskey fork), but this should not make difference.

Thank you,

Dalibor


Photon stuck in safe mode while upgrading to 0.7.0
#2

Are these devices under a PRODUCT_ID?
If not, a mere OTA flash of a 0.7.0 targeted application firmware should do all the right stuff, as long noone interferes with the prolonged flashing process with several reboots.
With PRODUCT_ID you need to make sure not to lock the system version.

Sure this is best tested with a local device, but I’ve had no issues with Safe Mode Healer (the auto-updater) lately - although others reported issues, but we don’t know whether the update process was allowed to run uninterrupted.


#3

Thank you @ScruffR,

right now the device is not under PRODUCT_ID.

I will prepare app compiled against 0.7.0, then it should be OK if I understand well.

“With PRODUCT_ID you need to make sure not to lock the system version.” - We dont use Console (we are on local cloud), so I guess this doesnt apply to our situation.

Will report back… Thanks!


#4

In that case Safe Mode Healer won’t be there for you - I missed that bit, sorry :blush: