Photon stuck in safe mode after remote flash

Via the web IDE I flashed firmware to a remote photon. I selected firmware target 0.7.0 (Default) as firmware target hoping that the Photon (carrying version 0.6.3) gets upgraded to the latest firmware version. The IDE tells me that flashing was successful but the Photon remains in safe mode (LED flashing violet) and the console reports 0.7.0-rc.6 as firmware, not the default 0.7.0 firmware. I tried re-flashing a couple of times, but it seems to be stuck both in safe-mode and at 0.7.0-rc.6. Any suggestions?

There’s an intermediate upgrade through 0.7.0-rc.6 that’s normal, but it might be stuck now.

Go to the 0.7.0 release site.


For updating OTA:

particle flash DEVICE_NAME system-part1-0.7.0-photon.bin
particle flash DEVICE_NAME system-part2-0.7.0-photon.bin
particle flash DEVICE_NAME bootloader-0.7.0-photon.bin

It’s good to watch the Events tab in the console and make sure the device comes back online in safe mode after each step.

For updating by USB:

In DFU mode (blinking yellow):

particle flash --usb system-part1-0.7.0-photon.bin
particle flash --usb system-part2-0.7.0-photon.bin

And in listening mode (blinking blue):

particle flash --serial bootloader-0.7.0-photon.bin

Normally the upgrade should work automatically the way you did it, but these steps will get you unstuck if the upgrade stops in safe mode.

Thanks @rickkas7, you are incredibly fast. Will try this later tonight and keep you posted.

@rickkas7: Rick, thanks again. Already after flashing the first file, i.e. the … part1…, (OTA) the photon booted regularly into the Particle cloud and showing up in the console as OS 0.7.0. Problem solved.