OTA flashing - now photon is offline

Doing OTA flashing to my remote devices in the field is nightmarish, and now I’m worried I need to make a trip out.

Photon was working just fine. I cannot recall what firmware it was originally on (maybe 0.53?). I tried flashing it with updated user firmware OTA with a target of 0.61, and now the device is offline.

What gives?? And is there any way to recover without driving 2 hours?

I managed to resolve this.

From the iOS app, I tried refreshing tinker, which seems to have worked. The device came back online and was “tinker-able”.

Then from the ParticleDev IDE I tried flashing my user firmware again, and it succeeded.

doing a “subscribe mine” when I refreshed my user firmware showed

  • spark/safe-mode-updater/updating and then
  • spark/flash/status (data “started”, followed by “succeeded”)

Then it came back online. PHEW. OTA updates shouldn’t cause heart attacks :slight_smile:

If you flash user code that has a higher version than the system version, it’ll try to auto-update. Not only does it take a bit of time, it can also fail (for the most random reasons, network issues being one), causing it to have to retry.
If it does have to update, give it some time to do so, and it should mostly work itself out.