How to add my argon to another account after unclaim or factory reset?

Hi, I’m using particle argon for the smart home experiment.
What I do is sending the argon boards to the participants’ home and let them add their argon boards to their accounts using their smartphones.
Before sending the argon boards, I wanted to test if the argon boards are working well.
So I added them to my account first and confirmed that they are working perfectly.
So I unclaimed the tested boards from my account,
and tried to add them to another test account to check if the participants can claim the boards to their accounts.
But here I found that the app doesn’t let me claim the boards to the test account, saying the error message below:

So I did the factory reset and tried to claim it again, but got the same error message.
I know I can add the device using the CLI tool manually, but I can’t ask the non-tech-savvy participants to do that.

So my question is,
is it “impossible” to reclaim an argon board to a different account using the smartphone app if the argon board has been claimed once before?

At that stage the claiming state of the device is not even considered since the phone app hasn’t even started talking to the device.

Just to reiterate what the app is asking: Is the device actually in Listening Mode (blinking dark blue)?

After I just unclaimed the device from my account (not the test account), the argon board is breathing cyan and I got the same error when I tried to reclaim it using the smartphone app.
So I factory reset the board and the board entered the listening mode, blinking dark blue.
And I got the same error when I tried to reclaim…
I just tried particle usb stop-listening to see what happens in CLI, but the board still remains listening mode. I guessed that’s because the board has no other state to resume out of the listening mode after the factory reset.

There are two possible causes for booting into Listening Mode on an Argon.

  1. the setup done flag may not be set
  2. there are no WiFi credentials stored on the device

Either or both of these may be true after a factory reset.
However, when the device is in Listening Mode you should be able to scan the data matrix of the device with the phone app and that should be able to establish a BLE connection with the Argon for further setup before even trying to claim the device to a specific account.

1 Like

Exactly. The LED light started breathing cyan after I setup the WiFi credentials using CLI, but I still could not claim the device using the phone app. I will try that setup done flag thing and test another argon board as well, thanks for the comment. And I will share the test result once I get the new argon board.

Hey, you were right!!
I tried particle usb setup-done in CLI, and now I can reclaim the device in my mobile app!
You saved my day, thx a lot!

1 Like

Hi @ScruffR, I really appreciate your previous help, but it again fails to reclaim the device with the same issue. As a recap, I have walked through the steps below:

  1. unclaim my argon device on web IDE (particle build)
  2. factory-reset my argon device
  3. (optional) update the firmware using CLI (particle flash --usb tinker; particle update)
  4. run command “particle usb setup-done” in CLI
  5. claim the argon device using the mobile (Android) app

But I get the same issue so I wonder if you have any idea on this.

I can only reiterate the same as I said earlier

Other than that I can only suggest you open a support ticket at support.particle.io as I have never expereinced such issues that were not solvable via the mobile app alone.

1 Like

I found how to fix this issue: just rebooting my smartphone! Unbelievable… I think there is a halting state somewhere in the smartphone-side network interface, and it was blocking the paring procedure. It’s stupid, but I’m very happy to make it work again. Thx @ScruffR!!

1 Like