Hard fault after particle doctor


#1

Hi :smiley:

I have an electron with a 3rd-party SIM.

It was working well some days but then the RGB led started flashing cyan but very quickly. I used particle device doctor and the led stopped flashing so fast but restarted after a while showing error code Hard fault.

I tried loading another firmware version (0.7.0 and 0.8.0-rc.8) but it still has the same problem. I used the particle doctor again but continue with the same problem.

Could you help me solve it?:cold_sweat:


#2

What does the device do when engaging Safe Mode?
Are you using the most recent version of CLI (currently 1.32.4)?

With that installed, you can try

particle flash --usb tinker
particle update

#3

Yes, it is the latest version of particle CLI.
Selecci%C3%B3n_022
I can’t enter Safe Mode, I press Mode and Reset, I release the reset and when it starts to flash in magenta, I release Mode but the Electron restarts trying to connect to the cloud.

I already tried running the commands but the problem persists, it connects to the cloud and after a few seconds shows Hard fault error.