Grey Circle Instead of Coloured Circle in Particle IOS app

I have set up a new Particle Photon. It has successfully connected to my wifi network. My computer can access the web through the Photon’s wifi. The Photon is breathing cyan. When I sign into the iOS app on my iPhone and look at the list of devices the Photon shows up with the correct name but the circle that shows status is grey, not green, red, or yellow.

When I do a command line query “particle list” I get “(Photon) is offline”.
When I try to do a command line flash of tinker the flash fails with a “Flash device failed Timed out.”

All the while the Photon is happily breathing cyan.

What does this mean ?

What code is running on your device?
If you are running some application that keeps the device occupied but checks in at the cloud every 10sec or so, the connectino will be degraded but the device never learns about that fact.
Try Safe Mode or particle flash --usb tinker to circumvent any problem caused by the running application.

1 Like

It is a brand new device, so I believe it would be only running tinker, but I do not know for sure.

I tried to get it into safe mode, but when I release the RESET button, the led does flash magenta, but when I release the SETUP button the led flashes white once, then rapid green, then rapid cyan, the breathing cyan. It does not go into safe mode.

When setting the mode, if I hold the RESET button down longer the led flashes yellow and when I release the RESET button the Photon does enter and stay in DFU mode.

I tried setting up the Photon again. I used the USB method. The setup said it was success, but “particle list” says the Photon is offline. Here is my terminal output. I deleted all the PROTIP lines.

27-iMac:~ chrismigdal$ particle setup
 _ __             _   _      _        
| '_ \  __ _ _ __| |_(_) ___| | ___ 
| |_) |/ _` | '__| __| |/ __| |/ _ \
|  __/| (_| | |  | |_| | (__| |  __/
|_|    \__,_|_|   \__|_|\___|_|\___|

> Setup is easy! Let's get started...
> It appears as though you are already logged in as
? Would you like to use this account? Yes

> No devices detected via USB.
? Would you like to scan for nearby Photons in Wi-Fi setup mode? Yes

? Found "Photon-BJ9S". Would you like to perform setup on this one now? Yes

> Obtained magical secure claim code.

> Hey! We successfully connected to Photon-BJ9S

> Now to configure our precious Photon-BJ9S

? Shall I have the Photon scan for available Wi-Fi networks? Yes
? Please select the network to which your Photon should connect: Five Redwoods N
? Please enter your network password: xxxxxx
> Here's what we're going to send to the Photon:

> Wi-Fi Network: Five Redwoods Network
> Security: WPA2
> Password: xxxxxxx

? Would you like to continue with the information shown above? Yes

> Obtaining device information...
> Setting up device id 220027000247343337373738
> Requesting public key from the device...
> Setting the magical cloud claim code...
> Telling the Photon to apply your Wi-Fi configuration...
> The Photon will now attempt to connect to your Wi-Fi network...

> It looks like your Photon has made it happily to the cloud!

? What would you like to call your Photon (Enter to skip)? ChrisIOT

> Your Photon has been given the name ChrisIOT
> Congratulations! You've just won the internet!

> Ok, bye! Don't forget `particle help` if you're stuck! <3
27-iMac:~ chrismigdal$ particle list
ChrisIOT [220027000247343337373738] (Photon) is offline

Forget the status info for now.

Make sure you have CLI v1.27.0 installed (particle --version)
Put your device into DFU Mode and run

particle update
particle flash --usb tinker

Put the devcie into Listening Mode and run

particle identify
27-iMac:~ chrismigdal$ particle --version

27-iMac:~ chrismigdal$ particle update

> Your device is ready for a system update.
> This process should take about 30 seconds. Here it goes!

! An error occurred while attempting to update the system firmware of your device:

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

dfu-util: Error during download get_status

> Please visit our community forums for help with this error:

27-iMac:~ chrismigdal$ particle flash --usb tinker

Found DFU device 2b04:d006
spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D /Users/chrismigdal/.particle/node_modules/particle-cli/binaries/photon_tinker.bin
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 3952
Download	[=========================] 100%         3952 bytes
Download done.
File downloaded successfully

Flash success!
27-iMac:~ chrismigdal$ particle identify

! serial: Serial timed out

I did a setup using a Personal Hotspot on my iPhone and after a couple of attempts I was able to connect to the cloud and actually see the Photon on my Particle app on my iPhone.

Also particle list does work.

27-iMac:~ chrismigdal$ particle list
ChrisIOT [220027000247343337373738] (Photon) is online
int digitalread(String args)
int digitalwrite(String args)
int analogread(String args)
int analogwrite(String args)

The error message while doing particle update may need some attention.