Got my Boron-LTE, blinking green

I received my pre-order Boron and Xenon. I went ahead with setting up the Boron first.

Everything went smoothly with the mobile iPhone app, until it was time to activate the SIM and connect to the Internet/Cloud. (As part of the setup, the app updated the Boron’s FW. I would assume that this was done from the iPhone via BLE? Slick! The FW update seemed to complete successfully.)

Post supposed SIM activation, I’ve now got a blinking (not breathing) green Boron.

  1. I’m in the US (A few miles north of Longmont, Colorado). I have no idea if LTE-M1 service is available here.

  2. Yes, the antenna is connected :slight_smile:

  3. I have a battery connected that came with one of my electron kits. I’ve tried both with USB connected and not. Tried moving the Boron close to a window, in case signal is weak.

  4. I agreed to sign up for the $4.95/month service, through the app, which I guess includes both cellular and 1 mesh gateway. However, I don’t see that I’ve signed up the Boron in the particle console. (While I do see my 5 electrons and 1 photon).

I just ordered an Ethernet featherwing, as I think it will be handy for development purposes.

Not sure what to do from here… Any help appreciated!



While I waited with blinking green for about an hour, I just stood up and looked at my Boron sitting in the window sill and it’s now breathing cyan.

Either someone at Particle fixed something right quick, or it just took a while.

In any case, I think things are good now.




Now I’m trying to setup the Xenon, and I realized that I think I have not finished setting up the Boron’s mesh network. (The Boron needs to act as the gateway.)

The Xenon sees no mesh network, and when I click on the mesh network setup tab in the particle web console, there are no mesh networks, but there is a message “Create a Mesh Network to connect Mesh devices to each other”, then a “set up a device” button.

Clicking on “set up a device” in the console takes me back to the mesh device setup sequence, which (if executed for the Boron) lands on a “See you back here in a bit!” page where it is waiting for me to finishing setting up from the mobile app. However, setup in the app can no longer communicate with the Boron as a new device – presumably because the Boron is now breathing cyan rather than blinking blue.

In short, I think I’m stuck because the cellular activation took so long (so I left the first pass of the setup sequence in the mobile app).

How can I finish the Boron’s mesh setup (as a gateway), now that it is connected successfully to the particle cloud?



You can always put the device back into Listening/Setup Mode be holding down the MODE button for 3+ seconds. If you hold the button pressed for 10+seconds, till it flashes blue fast, you also reset some settings you entered during your last setup, providing you with a “cleaner” starting state.

1 Like

Thanks, ScruffR. That did it. Both devices are now connected to the cloud :slight_smile:


Does anyone know how to fix it if the blinking blue light starts blinking green during the setup?