Flash Cyan and Red and computer crashes

I have a particle photon that will flash cyan a few times then one flash of red. After a bit it just goes to flashing cyan.
I was going to try to fix it with the CLI but whenever I plug it into my computer it causes the computer to crash and go to the Blue Screen. I have no clue what to do. It has been doing this for a few days, I have tried reinstalling the CLI with no success. My other Photon works with CLI just fine.
Please Help

Try pressing on the SETUP button before plugging into your PC till it enters DFU mode (blinking yellow)

That worked, Thankyou!! However now I have run into a new problem… I try to use the Key stuff but this popus up:

C:\Users\Seserie>particle keys new
Found DFU device 2b04:d006
Error creating keys... Error: Command failed: C:\Windows\system32\cmd.exe /s /c
"openssl genrsa -out device.pem 1024"
'openssl' is not recognized as an internal or external command,
operable program or batch file.

And OpenSSL is installed on my hard drive.

Another Update: I got OpenSSL to work!!
It connects to the cloud now!! However, It still crashes my computer when I plug it in…
Any Ideas?
I am just powering it off another particle for the moment.