Flash a Fac Default core, no LED unresponsive

Ok, well this has been exciting. I have some (what are now I believe considered old?) of the white cores, from the first or second kickstarter batch that I haven’t had time to play with for about 6 months. I am starting to have some free time again and just getting these off the ground is incredibly rough right now…

Here is all I am doing: Plugging them in, reset them to factory default, join to the cloud and finally flash them.

I am a master of resetting to factory default at this point, at least 20 times tonight alone. They join the cloud with no problem at all, and then I try to flash them, with ANYTHING. A complicated sketch from the library (the DHT22 one), then a simple one that just changes the color of the main LED on the core every few seconds, finally to just trying to flash them with Tinker.

All of these attempts result in the same exact scenario, dead, completely unresponsive core with no main LED (just the tiny blue one next to it barely lit up). Unplugging the core does nothing, it doesn’t show up in my device manager (windows) so I can’t even serial into it…

Everything works fine, right up to the flashing part, it happily joins the cloud, EVERY TIME.

I have tried 2 different cores and 2 different WIFI AP’s and even 2 different Wifi Antennas (I have the cores you put a little antenna on). Everything fails regardless of what I do, I am guessing this has something to do with the newest big update the team did? I am kinda guessing that the factory update means they go back to like version 1.0 or something??? Am I right about that? Because the flash from a factory default takes a LOOOONG time (I had successfully flashed one of these a couple months ago), but now it just seems like its trying to upgrade so much and download so much data that it’s just locking up before it can finish everything.

How can I fix this? I don’t know where to begin! Can someone help me out?

Thank you!


Yes that’s right.

You can update the factory firmware using the Spark-cli tool!

The command will be spark flash --factory tinker.

Be sure to update Spark-cli to the latest first. :wink:

I think you can try updating the CC3000 firmware to improve stability. :slight_smile:

I’m having the same problem with 3 Sparks. After pushing a new app to the spark I only see the small blue light on. I tried factory reset and DFU and nothing happened. I’m going to try pushing an old firmware next.