Cannot flash the core more than once without requiring a factory reset

I cannot seem to flash firmware more than once, maybe twice at most. After that, the core does not respond and I have to factory reset the core. Without a factory reset, it doesn’t start flashing purple, and I get the: “The server has failed to process the request on time. Please try again” error message.

This happens with both my cores, so I think it is a server issue, rather than my specific hardware. Is anyone else encountering similar problems?

(I tidied up this post as it became a running monologue of the problems I encountered!)

Yup, I am seeing this too.

Interestingly, the sample program to flash the led lets the Spark operate as advertised. If I add a little on, it exhibits the hear-no-evil behaviour that @dermotos sees.

1 Like

I wiped both my cores and tried to flash them again last night (~20 hours ago from now) and they seemed to work, but just tried again now and it doesn’t work again.

It’s clear it’s not going to work after a few seconds of hitting the flash button, when the core’s LED doesn’t start flashing purple.

Hey guys - just created a new thread for this issue, which relates to blocking user code: