Firmware.bin file fails to Download, OS X

I made a change to my user firmware file today in web IDE and when I clicked on “Compile and Download firmware file” the Firmware.bin file does not appear anymore in the ~/Downloads folder. This worked many times during last 10 days.
I tried Particle CLI and type "particle version or particle help I get this response-----

-bash: syntax error near unexpected token `newline’

I logged out and now I can’t log back in (fails login using correct PW)
I can login to Wed IDE using same PW that fails on CLI.
typed cd /dev on Terminal app, 10.12.5 then type ls and and there is no longer a serial choice like, /dev/tty.usbmodemXXXX,to choose, it was /dev/tty.usbmodem1431 9600, worked on 9/16.
Tried Restarting numerous times.
I don’t know what to do.

Just did another Restart and tty.usbmodem1431 shows up now.
Typed $ particle serial list
No devices available via serial

This was due to operator error, turns out I was using an older password. I now am logged into CLI.

This is still not working using the Web IDE link “Compile and Download” I’m not sure whats going on. Just clicked the link in the IDE it Spins and comes back with Code Verified! Great Work but there is no file sent veto my ~/Downloads folder, I searched my entire disk using the Finder an nothing shows up named firmware.bin.

Would you be interested in using another development tool to compile your project? You could use Particle Dev, particle-cli, or po-util.

Also, regarding your issue, what browser are you using? Do you have any content blockers that may be interfering with the Web IDE?

I’m using Safari 10.1.1. I’ve tried other sites that download pdf’s, banking sites are no problem. I started up a Mac mini this morning and it was able to Download from the Cloud, 10.11.16 Safari 10.11.2. So I transferred the firmware.bin file to my laptop and used Particle CLI to update the Electron over USB.
Just checked the mini, and Safari Block Pop Windows was unchecked. It was Checked on the laptop sp I unchecked it and Restarted Safari. Now the link is working. Great! but I wonder what the state of the box was on Saturday when I had no problems Downloading from the Cloud.
Thanks so much for responding.:grinning: