Firmware 0.4.9 breaks SoftAP

mdma,

SoftAP no longer works with this update, I must roll back to 0.4.7 for my SoftAp implementation to work. Verified same results with http://photonsoftap.meteor.com/ .

Two requests:

  1. Fix firmware to work with SoftAP
  2. Test against http://photonsoftap.meteor.com/ or other SoftAp client before releasing firmware.

Thanks
Barry

Your post is a little abrupt so I’m sensing you’re frustrated from things not working for you.

I just tried this against 0.4.9 on a Photon with no wifi credentials configured each time, both with our internal softAP HTTP test client, and the meteor client you listed above. In both cases, the Photon successfully received the credentials and connected to the WiFi network.

While we’re already asking things of each other, I have 2 requests of my own:

  • please describe in detail what doesn’t work for you so we can follow the same steps and have the greatest chance of reproducing the problem, making best use of both our time.

  • please refrain from assuming that because something doesn’t work for you that it hasn’t been tested. We spend a great deal of time testing each change to the release, and the release as a whole.

The softAP setup worked for me both times, so I’m out of ideas unless you can provide more details about the nature of the failure and the steps to reproduce it.

4 Likes

SoftAP is awesome and in my opinion the best way to setup a Photon. And setup is critical to the success of any product that uses Photon. So yes, I highly value SoftAP integrity.

The only other information which may help is that both Photons that had this problem were new out of the box.

After using the Photon app to get both connected, I flashed a program with 0.4.7, put it back to blinking blue, and SoftAP worked. This was the basis of my bug report.

Just now, I flashed the same photon with the same program with 0.4.9, put it back to blinking blue, and SoftAP worked.

So the case where SoftAP failed was limited to an out of the box attempt to setup with SoftAP.

Appreciate the quick response.

Barry

And that’s probably where the issue is. “new out of the box” devices don’t get updated to latest automatically. I’m not sure what version they’re on, but it’s probably one before softAP was supported in the first place.

That triggered an OTA update, which got 0.4.7 installed, which does support softAP.

You flashed/updated to 0.4.9, which still has softAP support, thus it works.

Since we’re on the ‘requesting things’ topic:

  1. Next time, please make sure it’s no user error before blaming it on the hard work of others. Actually checking what version you were on, before shouting “this doesn’t work, fix it!”, would’ve most likely prevented this whole ordeal.
  2. Try to be a bit more descriptive with your “bug” reports. “This doesn’t work, fix it” is awfully condescending towards those that have put hard work into it, automatically blaming it on them. It’s also not helping anyone, since no actual information is included. Without any steps to reproduce an issue, it’s virtually impossible to find the cause of it, let alone fix it.

That said, glad to hear it’s working again.

1 Like

Ouf of the box photons do not support HTTP SoftAP, only TCP SoftAP. HTTP was added at a later time.

There is a new manufacturing run of Photons that will ship with 0.4.9 firmware, that provides HTTP SoftAP support out the box.

2 Likes

To add to this, if you buy a Photon from a reseller now or in future you still can’t be certain to get an already updated device, since you won’t know which batch it came from, but this info from the docs will be valid allways

https://docs.particle.io/guide/getting-started/start/photon/#step-2-connect-with-your-smartphone

So in future please try the bug tracking on your own end first.
And bug reports without crucial info like “new out of the box” don’t deserve the name “bug report” - the original post is closer to a rant, which are not appreciated

1 Like