Application softAP http pages issue

I Flashed the softap code from the git report a few days ago, tested and everything was great, reset all wifi credentials and connected fine. We had an issue with cox communications, they came out and replaced our modem, and since then my photon will not connect.
I’ve tried resetting wifi credentials again and connecting to the photon, then going to, but this no longer brings me to the softap page, but instead downloads a file named “hello”. Even worse, this file has an unknown extension so I can’t even find out what it is.

You can try using the CLI or mobile app to setup wifi credentials for now.

Did the user firmware changed or something? That might cause the softAP pages to not load.

This is the default behaviour of SoftAP if you have not got a user SoftAP firmware installed on the device.
The file is just a plain text file containing

Soft AP Setup 

Could it be that you used the wrong Photon or had other code flashed in between?

Never flashed any code in between, it was connected, then after the modem was changed it would flash green, then cyan, but never start breathing cyan, then go back to green. I’ll connect it using the CLI today, just wondering if anyone else has run across this, or if there is something else to look for

Be sure to initialize the softAP pages in a STARTUP() macro so they are setup before the device connects to the internet.

If yo have it initialized in the setup() method, then the SoftAP pages won’t be available until the device has connected to the cloud.

I recently made a change to the example app to reflect this:

STARTUP(softap_set_application_page_handler(myPage, nullptr));

This isn’t a fix but merely a workaround for the fact that your photon is no longer able to connect to the internet, which may be a problem with your new router. Double check that port 5683 is open for outgoing traffic.

1 Like

New development in this, I had to reflash the tinker software in dfu, even after doing this it wouldn’t connect, I tried unclaiming the photon, and the tinker app would find it, but was never able to connect to it. Eventually I manually connected using putty, and everything seems to work ok, but I’m not sure what caused any of this.

Still having issues with this, I was able to connect to my home WIFI using putty, and have been running some code here, bought a new external duck antenna from particle, tested my range here at home, range is awesome by the way. Took my setup to my shop to do some more testing and I can’t connect with the particle app, the photon is running the tinker firmware, the only difference is the STARTUP(WiFi.selectAntenna(ANT_EXTERNAL));
In the app it sees the photon, and when I try to connect to it, it shows connecting or trying to connect and has the circle spinning, but then just times out and shows an error of not being able to connect to “Photonxxxx”