Examples folder not importing from Git?

Im trying to import a new Library for ADS1115 16-bit ADC board and everything works well and samples I made runs great…

The Library also imports and I can code against it…

BUT - for some reason the “examples” folder on GitHub project is being ignored when importing?

I even get a message “examples/” folder not found when I import… but its there, FOR SURE! ?

Any ideas?

Id ideally like to publish the library, but my samples are being ignored on import?

If you post the link to your repo it’d be easier to look into it :wink:

You could also add your GitHub account to your Particle profile which would also help locating your repo.

Till then I’d only guess that you have the examples folder not in the right location (<repo>/firmware/examples)

AH - well there was the problem… for some reason i thought the examples folder should be in the root…

moved it over and works GREAT!

I could swear i intently looked at the sample library and built the structure based on that… I guess I should just have RTFM’ed a little better :smile:


Well, I guess I spoked too soon…

I re-imported the library and worked great, with samples, then I “Published” so everyone can get it…

And now the BUILD environment hangs up with a blank spinner screen whenever I try to click on that library of mine…

Also, even although I published it, it doesnt show up publicly when I search it??

But really the biggest issue is that the entire development UI just hangs when I go to “Libraries” and clicked on my Library in question… I have to close the browser and open it up again…

easy to repro… simply go and click on the library…

Just sits there and spins forever…

I had this problem sometime too.
Using incognito mode on your browser or applying CLEAR CHACHE in the settings drawer did usually solve that problem.

At the moment I can’t see your lib either, so I guess the publishing didn’t succede.

Tried a different browser with cache cleared and was able to at least not let it hang up anymore…

But, my “Published” library doesnt show up in search… I assume it has to go through some vetting process?

Shows as “Published” below:

But the “Search” turns up empty… ?

After a CLEAR CACHE and REFRESH LIBRARIES I can see your lib

1 Like


Thanks, great news!

BTW: You’ll never find your own libraries via the search feature, since they will always be in your “MY LIBRARIES” section.
It’s the eye icon (crossed off or not) next to the library title and the little flag next to the usage count that tells the difference between published and private.

1 Like

cool - Thanks a bunch for the help!

1 Like