Electrons suddenly stopped reconnecting


#1

Hi all, strange one here, need help!

I have an electron in a remote setting, sending data gathered at a tank in the desert in Arizona. It’s been working out there for the past year. New firmware was sent to it earlier in the week, but it had been rock solid since. At 0200 Az time Thursday it unexpectedly stopped.

I got out to it on Saturday, as I happened to be in the Arizona for the weekend, and the unit is running its code, but after trying unsuccessfully to connect for 2 min, it goes back to sleep for an hour, when it tries again.

I tried safe mode as well, and it will not go past blinking green in its startup sequence, even after trying for 20 minutes.

I had another unit with me, programmed with the previous version of code (which ran reliably for a month) and substituted it for the electron that would not connect. With this one in place, it connected normally and sent it’s data…once. Subsequent connections did not complete, stuck on flashing green after trying reset, battery disconnect, and safe mode.

I then tried an E series that I had with me, which also would connect just once, and not again.

As I drove away after putting back the original unit, I left the e-series unit live, and when I got about 10-15 miles away, it reconnected and started working normally.

I feel confident it’s not my code, as other units with the previous version, which is proven stable code, exhibit the same behavior.

It seems to me that there is some sort of local error, that is just in that particular area, maybe just one cell tower.

But I’m at a loss as to how I can proceed to troubleshoot and fix the issue.

Ideas?

J


#2

OK, lets try a different way. How can I get some support for a product that connects in one location, but will not connect in the place it is installed, even though it has been working there for the last year?

J


#3

It makes it difficult if you can’t access the remote location where the Electron is deployed.

How far away is this location from where you are normally?


#4

@RWB: I’m occasionally in Colorado, but that’s the closest I get most of the time. So not very close! As it stands currently I’m in Florida.

I can occasionally get someone out to the tank to push buttons if we need a reset or something like that, but they are not tech savvy.

But as I said, I am confident that the problem is not with the device, since others that function correctly exhibit the same behavior, and then they start to work again when I relocate them.

And as the unit stands now, it is trying to reconnect every hour, then goes back to sleep.