Electron connects well for a period, then stops connecting and never recovers

electron
Tags: #<Tag:0x00007f1ca2f655e8>

#1

Hi All,

I’m having a problem with an electron in a remote installation. It wakes every 15 minutes, checks battery power is adequate, connects to cloud (with a timeout of 180 seconds) and sends sensor data, then sleeps again.

When first I deployed it, it connected well for ten days or so, then wouldn’t reconnect again. When I got out to it, reset it by either hitting reset button or cycling the power, and it reconnected, and worked for about a week. Next time, I replaced the electron with another, and it worked for a few days also. Recently I went out again, reset, and it worked for a day, and on the next go around, it only worked for 12 hours.

When it works, it connects and behaves as expected, waking, sending, sleeping, the battery state is always in the 80% range, the cell signal is indicated in diagnostics as fair. Whenever I reset it, it works for some period of time before it stops connecting.

Why would it connect fine for a day or two, and then not connect again after that? I have two others nearby (accessing the same cell tower) and using the same firmware that don’t exhibit this problem, and will always reconnect even after missed connections. The others indicate good cellular signal, so I suspect that this is related to a weaker signal, but the part I cannot understand is that it always comes back to life if we hit the reset button.

J