Electron will not connect to local cloud, generating EC instead of RSA key and other issues

Trying to follow this Cloud solution guide:
but it’s not detailed/updated enough…

The particle keys doctor command gives me an error because it expects and RSA key and it gets an EC key. How can I force CLI to generate a RSA key?

Regarding step 3 - 6 , they need to be updated a bit.

In step 3 I log in and it has detected my electron but then it exit with a statement that it cannot be setup via the CLI?! and “We need to collect billing information… please visit …setup.particle.io” but the billing information is already in active in the https://console.particle.io/billing.

It has to be run in a separate CMD than the one that runs the server. I am running the setup on a different PC than where the particle server(node main.js) runs. Since the particle setup command exit by itself, I never "Perform Ctrl + C " part.
I do step 4 on PC that is connected to Electron via USB, step 5 is good it is flashing yellow. I run the command in Step 6 with and without “–protocol tcp” added in the end.
It seem like it create a RSA file!

When I push reset on Electron it tries to connect to local cloud but without luck. Blinking cyan, then blinking red, single green repeat for a while.

I ran the particle config identify and it is pointing the API to the local server. Not sure what the access token is. Its doesn’t match the key. And what is the profile name used for?

Any insight is appreciated.