Electron does not breath cyan on first power up (connection problem)


This morning I started unpacking my new 3G Electron and progressing through the start guide. I didn’t get very far because after connecting the antenna and battery, my Electron doesn’t connect to the network, it just rapidly flashes white. Here is a video: https://www.youtube.com/watch?v=zZAiRloUrRo

What I’ve confirmed/tried with no success:
-I’ve correctly activated my SIM per Particle’s instructions
-Power cycling the device
-Pressing the ‘reset’ button
-Plugging into USB power (w/ battery)

Would a appreciate any help.

It looks more like rapidly flashing cyan.
https://docs.particle.io/guide/getting-started/modes/photon/#connecting-to-the-cloud (i know it says photon but i can’t find the electron equivalent docs)

Do you have a serial terminal installed or Particle CLI?

Thanks for your quick reply.

I just installed CLI and tried using it. It detects my Electron on USB, but reports to need billing information to set up and directs me to setup.particle.io, which I’ve already visited and setup my billing info before I encountered this problem.

Any other ideas, or am I missing something? Thanks.

  1. Can you place the device in Listening mode and run particle identify to check the system firmware version?

  2. Place the device in DFU mode and run particle flash --usb tinker-usb-debugging

  3. Next, hit reset and run particle serial monitor

You should see some logs printed in the console log. Paste it here so that we can see what’s the issue.

Thanks for sorry for the bummer!

1 Like

Thanks for the clear instructions.

Here’s some of the results from the serial monitor. Let me know if you need me to past over more.

Opening serial monitor for com port: "COM4"
Serial monitor opened successfully:
    16.783 AT read  +   16 "\r\n+USOST: 0,58\r\n"
    16.798 AT read OK    6 "\r\nOK\r\n"
    22.882 AT read  +   14 "\r\n+CIEV: 2,3\r\n"
0000024517:DEBUG: virtual particle::protocol::ProtocolError particle::protocol::DTLSMessageChannel::send(particle::prot...message length 29
0000024537:DEBUG: int Spark_Send_UDP(const unsigned char*, uint32_t, void*) (267):send 58
    24.551 AT send      36 "AT+USOST=0,\"\",5684,58\r\n"
    24.568 AT read  >    3 "\r\n@"
    24.621 AT send      58 "\x17\xfe\xfd\x00\x01\x00\x00\x00\x00\x00\x05\x00-\x00\x01\x00\x00\x00\x00\x00\x05\xd5T\xef\xda\xd0&\xdf\xc1)/\xb1k\xa8\xd7\x90\x81\xdb\xbeR\r\"F\xad\x10\x90\xef\x8e\xba\x11\x87\x86\xe4\x94\x19d\x95`"
    24.784 AT read  +   16 "\r\n+USOST: 0,58\r\n"
    24.799 AT read OK    6 "\r\nOK\r\n"
    25.883 AT read  +   14 "\r\n+CIEV: 2,2\r\n"
    26.888 AT read  +   14 "\r\n+CIEV: 2,3\r\n"
    27.883 AT read  +   14 "\r\n+CIEV: 2,2\r\n"
    30.888 AT read  +   14 "\r\n+CIEV: 2,3\r\n"
    31.883 AT read  +   14 "\r\n+CIEV: 2,2\r\n"
    33.888 AT read  +   14 "\r\n+CIEV: 2,3\r\n"
    37.113 AT read  +   14 "\r\n+CIEV: 2,2\r\n"
0000040518:DEBUG: virtual particle::protocol::ProtocolError particle::protocol::DTLSMessageChannel::send(particle::prot...message length 29
0000040538:DEBUG: int Spark_Send_UDP(const unsigned char*, uint32_t, void*) (267):send 58
    40.552 AT send      36 "AT+USOST=0,\"\",5684,58\r\n"
    41.959 AT read  >    3 "\r\n@"
    42.012 AT send      58 "\x17\xfe\xfd\x00\x01\x00\x00\x00\x00\x00\x06\x00-\x00\x01\x00\x00\x00\x00\x00\x06\x0e1&\ac\xbe1\xd8\x18\xb2\xceg4\x95e\xd6`2\x87\x13E\x838Z\xb0\xb0\x93\x95\x1c\xffq\x80\xeba\x926\xa7"
    42.174 AT read  +   16 "\r\n+USOST: 0,58\r\n"
    42.189 AT read OK    6 "\r\nOK\r\n"
                                                                                 0000072523:DEBUG: virtual particle::protocol::ProtocolError particle::protocol::DTLSMessageChannel::command(particle::p...session command: 0
0000072537:ERROR: int particle::protocol::Protocol::begin() (236):Hanshake: could not send hello message: 10
0000072548:WARN : void handle_cloud_connection(bool) (267):Cloud handshake failed, code=10
0000072808:INFO : void cloud_disconnect(bool) (421):Cloud: disconnecting
0000072815:DEBUG: int Spark_Disconnect() (905):Close Attempt
    72.823 AT send      12 "AT+USOCL=0\r\n"
    74.028 AT read OK    6 "\r\nOK\r\n"
0000074033:DEBUG: int Spark_Disconnect() (907):socket_close()=success
0000074041:INFO : void cloud_disconnect(bool) (434):Cloud: disconnected
0000074048:INFO : void establish_cloud_connection() (213):Cloud: connecting
0000074056:DEBUG: int Spark_Connect() (827):sparkSocket Now =-1
0000074063:DEBUG: int Spark_Connect() (846):HAL_FLASH_Read_ServerAddress() = type:1,domain:$id.udp.particle.io,ip:, port: 65535
    74.077 AT send      56 "AT+UDNSRN=0,\"270037000d51363034323832.udp.particle.io\"\r\n"
    76.977 AT read  +   28 "\r\n+UDNSRN: \"\"\r\n"
    76.994 AT read OK    6 "\r\nOK\r\n"
0000076999:INFO : int determine_connection_address(IPAddress&, uint16_t&, ServerAddress&, bool) (796):Resolved host 270037000d51363034323832.udp.particle.io to
    77.018 AT send      18 "AT+USOCR=17,5684\r\n"
    77.034 AT read  +   13 "\r\n+USOCR: 0\r\n"
    77.049 AT read OK    6 "\r\nOK\r\n"
Socket 0: handle 0 was created
0000077056:DEBUG: int Spark_Connect() (857):socketed udp=1, sparkSocket=0, 1
0000077064:DEBUG: int Spark_Connect() (867):connection attempt to
0000077073:INFO : void establish_cloud_connection() (220):Cloud socket connected
0000077081:DEBUG: int Spark_Handshake(bool) (539):starting handshake announce=0
0000077091:DEBUG: int Spark_Send_UDP(const unsigned char*, uint32_t, void*) (267):send 107
    77.105 AT send      37 "AT+USOST=0,\"\",5684,107\r\n"
    77.123 AT read  >    3 "\r\n@"
    77.176 AT send     107 "\x16\xfe\xfd\x00\x00\x00\x00\x00\x00\x00\x00\x00^\x01\x00\x00R\x00\x00\x00\x00\x00\x00\x00R\xfe\xfd\x1a+E\xee\xd2\xe5I\bdU\xce\xc7\x12\xf7R\an\xebKf\x90=\x90\x89\xa8\xca\x03\xc8\xa2\xb5J\x03\x00\x00\x00\x04\xc0\xae\x00\xff\x01\x00\x00$\x00\r\x00\x06\x00\x04\x04\x03\x03\x03\x00\n\x00\x04\x00\x02\x00\x17\x00\v\x00\x02\x01\x00\x00\x13\x00\x02\x01\x02\x00\x14\x00\x02\x01\x02"
    77.358 AT read  +   17 "\r\n+USOST: 0,107\r\n"
    77.373 AT read OK    6 "\r\nOK\r\n"
    77.667 AT read  +   17 "\r\n+UUSORD: 0,60\r\n"
Socket 0: handle 0 has 60 bytes pending
    77.686 AT send      16 "AT+USORF=0,813\r\n"
    77.711 AT read  +   98 "\r\n+USORF: 0,\"\",5684,60,\"\x16\xfe\xfd\x00\x00\x00\x00\x00\x00\x00\x00\x00/\x03\x00\x00#\x00\x00\x00\x00\x00\x00\x00#\xfe\xfd X\xf3\x1f)\xc2{[2-\xc4\x93\x9e\xe6jkv\xe9\xa5L\xcc\tq|\x8a\xc37>\xff\x8e5.\x96\""
    77.747 AT read OK    6 "\r\nOK\r\n"
0000077751:DEBUG: int Spark_Receive_UDP(unsigned char*, uint32_t, void*) (285):received 60
0000077760:DEBUG: int Spark_Send_UDP(const unsigned char*, uint32_t, void*) (267):send 139
    77.774 AT send      37 "AT+USOST=0,\"\",5684,139\r\n"
    77.792 AT read  >    3 "\r\n@"
    77.845 AT send     139 "\x16\xfe\xfd\x00\x00\x00\x00\x00\x00\x00\x01\x00~\x01\x00\x00r\x00\x01\x00\x00\x00\x00\x00r\xfe\xfd\x1a+E\xee\xd2\xe5I\bdU\xce\xc7\x12\xf7R\an\xebKf\x90=\x90\x89\xa8\xca\x03\xc8\xa2\xb5J\x03\x00 X\xf3\x1f)\xc2{[2-\xc4\x93\x9e\xe6jkv\xe9\xa5L\xcc\tq|\x8a\xc37>\xff\x8e5.\x96\x00\x04\xc0\xae\x00\xff\x01\x00\x00$\x00\r\x00\x06\x00\x04\x04\x03\x03\x03\x00\n\x00\x04\x00\x02\x00\x17\x00\v\x00\x02\x01\x00\x00\x13\x00\x02\x01\x02\x00\x14\x00\x02\x01\x02"
    78.045 AT read  +   17 "\r\n+USOST: 0,139\r\n"
    78.060 AT read OK    6 "\r\nOK\r\n"
    78.374 AT read  +   18 "\r\n+UUSORD: 0,344\r\n"
Socket 0: handle 0 has 344 bytes pending
    78.394 AT send      16 "AT+USORF=0,813\r\n"
    78.419 AT read  +  157 "\r\n+USORF: 0,\"\",5684,118,\"\x16\xfe\xfd\x00\x00\x00\x00\x00\x00\x00\x01\x00i\x02\x00\x00]\x00\x01\x00\x00\x00\x00\x00]\xfe\xfdX\xf3\x1f)Q\xd9<\b\x9a&9\x9d\xcf\r\x91QN:\xe2G\x9cN\x00E'\x95?|N\x05\xaf( \xf2U\xf6\f\xd8\xdb\x01\x16u`FO\xd7\xc7\xab\xe9f\xea\xa7\x9d\xf3\xddE\xda\xa3 B4e\x8a\x81\xf5\xc0\xae\x00\x00\x15\xff\x01\x00\x01\x00\x00\v\x00\x02\x01\x00\x00\x13\x00\x01\x02\x00\x14\x00\x01\x02\""
    78.475 AT read OK    6 "\r\nOK\r\n"
0000078479:DEBUG: int Spark_Receive_UDP(unsigned char*, uint32_t, void*) (285):received 118
    78.488 AT read  +   18 "\r\n+UUSORF: 0,226\r\n"
Socket 0: handle 0 has 226 bytes pending
    78.508 AT send      16 "AT+USORF=0,813\r\n"
    78.543 AT read  +  207 "\r\n+USORF: 0,\"\",5684,168,\"\x16\xfe\xfd\x00\x00\x00\x00\x00\x00\x00\x02\x00\x9b\f\x00\x00\x8f\x00\x02\x00\x00\x00\x00\x00\x8f\x03\x00\x17A\x04\xe0\x1f\x93 \x87=\x18\xd5\x9e\xdb\xde\x0fxZ\xe0\xc8a~5rN\xc5)\xde\xdd\xd8\xe2\xe0F\xd4\x8ca\xde\x02\xb6~|\xe9\xe6\xba\x82\xd9r\xfd\xe7\x16\x1ex\x92\xff\xd5]\xb4\v%n\a\xb0%\x1f\xae\xdbM[\x04\x03\x00F0D\x02 d \xac\xa0'R\x1a\xbe\x89\xde\x137\xbd4Lo\x0e\r{Q\t\xeaW\xae \a\x9a\xb2W\xd9\x9cI\x02 \x15\xa2f^^\f\x12\x86\xb2\xe3;<U\xca\xad\xe6'\xb3\x8f\xaeG\xd4\xc52$\x95t\xea\x01\x1dU\xf0\""
    78.613 AT read OK    6 "\r\nOK\r\n"

What is your system firmware?


Ok do the following. Be sure not to skip steps as system firmware will be upgraded:

  1. npm install -g particle-cli@v1.17.0
  2. particle --version check that it is 1.17.0
  3. Place the device in DFU mode
  4. Run particle update
  5. npm install -g particle-cli
  6. particle --version check that it is 1.21.0
  7. Place the device in DFU mode
  8. Run particle update
  9. Hit reset and see if it connects well

For some reason I’m having trouble installing v1.17.0 of particle CLI. When I run npm update -g particle-cli@v1.17.0 and then particle --version, it always returns v1.21.0.

Have you ever ran into this problem before?

Try doing npm uninstall -g particle-cli first. then do npm install -g particle-cli@v1.17.0 instead of update

Thanks, got it. Needed to use sudo

Ran the 9 step procedure you outlined above - no change in behavior - still seeing rapidly flashing cyan.

Ran particle identify and confirmed my firmware has been updated to 0.6.1.

Any more ideas?

Thanks for the support.

Let’s try this final thing and see if it works.

  1. place the device in listening mode
  2. run particle identify and copy the device id
  3. place the device in DFU mode
  4. run particle keys server
  5. run particle keys doctor PASTE_DEVICE_ID

If this still does not work, i will loop in the electron man :smiley:

No luck. when I run particle keys doctor 'MY_DEVICE_ID' I get an error:

Error sending public key to server: Permission Denied Make sure your device is in DFU mode (blinking yellow), and that your computer is online. Error - undefined

I can confirm with confidence that my Electron is in DFU mode and my computer is online.

Thanks for your support, but I think it’s time to bring in the electron man.

You do have no single quotes around your device ID I guess?
Have you updated CLI back to 1.21.0?
If you are on an older version of CLI these were a bit picky about capital hex digits (A…F) - if you have these, try to convert them to lower case (or vice versa).

Thant’s correct @ScruffR:

  • No single quotes around my actual device ID
  • CLI was updated back to 1.21.0 @kennethlimcp’s instructions
  • No uppercase characters in my device ID

Any other ideas?

@rickkas7 can you take a look?

One thing you could also try is to particle logout and particle login again.

@ScruffR just tried that, no luck. :frowning:

Can you PM me the exact command including your device ID?

@ScruffR there’s an issue with the electron connecting to the :cloud: during handshake so i don’t think claiming is coming into the picture (yet).