[ELECTRON] Unable to use Serial.println()

I am having serious problems developing my application and want to use Usb serial messages to debug my code. But I cannot get Usb Serial communication to work on my electron…

A simple Serial.begin(9600); Serial.println(“Hello world!”); won’t even show up in my terminal …

I tried particle serial monitor with the particle-cli but that gives no response.
I tried the USB terminal feature in particle dev but still nothing.

The cli does give me this

Found 1 device connected via serial:
/dev/cu.usbmodem1421 - Electron

but when I try to monitor it it just seems like its hanging or not doing anything… I have particel cli 1.17.0 and electron firmware 0.5.3

PS: the tinker-usb-debugging firmware does give me serial output…

[UPDATE] : When i flash my formware with --serial instead of --usb then it does work…

If that works, then so should other code.
Would you mind sharing your code?

Then it would be interesting to see the output of

particle flash --usb firmware.bin