[SOLVED] Serial.println("blah") doesn't output anything to my screen

I am using Particle CLI 1.18.0 with Windows 7 and a plain command prompt window with Particle (0.6.0) connected via USB.

In setup() I have Serial.begin(9600)

I can flash, and execute commands with arguments over USB.
Integer returns from called functions are shown in my command prompt window.

However, Serial.println(“anystr”) or Serial.println(func()) doesn’t output anything to my screen.
Likewise, Serial.isConnected() returns 0 for some reason.

Do I need to set up my ports in Windows somehow? Use a different baud rate? Use USBSerial instead?
I could use some help here.

You can try using CoolTerm or Putty and connect to the COM port and see if that works.

1 Like

Yes, thanks, the Putty thing worked. I saw that Electron was connected on COM7 on my computer, so making Putty connect to that port in serial mode showed that everything was getting output as it should.

I found too, that you can make the Particle CLI connect in read-only mode with "particle serial monitor COM7"
I haven’t found a way to get the Particle CLI to have an interactive conversation though and output responses to the same terminal. It seems necessary to have one terminal for inputs, and one for listening to responses.
Putty is probably far better at this than cmd.exe for sure, so I have to figure out a way to use Particle commands in a Putty shell.

1 Like