Electron - Unable to detect any devices in DFU Mode

After installing the correct drivers and checking the usb multiple times. Following the instructions for DFU mode i still get the error . I tried using “dfu-util -l” as suggest in another forum and it says cannot open DFUdevice. Any suggestions on how to proceed i need to update the firmware on the device.

C:\Users\co-op>particle update

!!! I was unable to detect any devices in DFU mode...

> Your device will blink yellow when in DFU mode.
> If your device is not blinking yellow, please:

1) Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

2) Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

3) Release the MODE/SETUP button once the device begins to blink yellow.

C:\Users\co-op>sudo dfu-util -l
'sudo' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\co-op>dfu-util -l
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Cannot open DFU device 2b04:d00a

Can you post a screenshot of Device Manager showing the DFU device and driver details?


Oh it thinks this is a photon ? i downloaded the drivers from the website and it says you dont need to install drivers for windows 10

So i used my mac and everything worked great. I just installed node.js and used “brew install dfu-util” then particle update and its good. Thanks for your help though.

What driver did you download?
It’s true, Win 10 won’t need drivers for USB Serial, but for DFU it still does - so I guess you just tried the wrong drivers.
If you had the correct ones, DevMgr would not list it under Other devices with a question mark and decorate the device with an exclamation mark.
And the fact that DevMgr can display the name string does not indicate the system knows what a Photon DFU Mode is.

So I still think this statement didn’t helping the diagnosing process.


Oh! that makes sense. So do you know where i can get the DFU drivers for the electron?

You could either download the CLI Installer which should also bring the drivers, or you use zadig to install just the DFU drivers as shown here


Thanks!!! this solves it!!:clap:

1 Like

Thanks ScruffR!

1 Like