Electron Solid dim blue D7 LED - Unresponsive

My electron is seemingly “locked” up with a constant solid cyan color. The firmware that was running on the device is very minimal with just a temperature read and Spark.publish(). I cannot reset the device or in anyway reboot the device. When I unplug the LiPo and USB and then plug it back in, the device continues it’s solid cyan color without doing any boot up sequence. It was working before and I had ran it for a long period of time (over night). I eventually drained the battery so I added rechargeable batteries and a solar panel to the VIN pin. The maximum power coming in was 5V at 2300 mAh, but I had the LiPo battery plugged in to keep things regulated at all times. Adding the rechargeable battery setup was when I started having issues, but I’m not sure if it’s related. Currently, only the LiPo battery is plugged in and I am still having these issues without any means of resetting my device. Any ideas on how to jog it out of this solid cyan “locked” state?

Two quick requests:

  1. Can you put the unit in Safe Mode or DFU Mode
  2. Can we get a quick video showing the device booting up?

I’ve tried numerous times to get the device into DFU or Safe mode and unfortunately I can’t. The device just continuously stays at the solid cyan no matter how long I hold either button or a combination there of. Here is a short video showing when I plug in the LiPo battery, the device instantly goes to the solid cyan.

Link to video: https://youtu.be/0rxN1YbY1eY

That’s not what we understand when you say “solid cyan” - that’s more commonly called “dim blue” or “dim D7 LED” which is a fault after “brownout” situations that’s still under investigation.
(Hence I’ll update your topic title accordingly - was “Electron Solid Cyan & Unresponsive”)

Thank you for bringing this to my attention. I appreciate the help a lot and will look into the “Bug Bounty” you linked above.

It seems like I am in similar situation and wondering if the source of this issue became known.
My customer returned the Electron to me with dim blue (not cyan and dimmer then in the video from kevinbartchlett) and otherwise non responsive. My client said he let the battery to discharge by accident. He then plugged it back in USB to charge. The device got in this state and never functioned again.
I changed the charger and changed the battery with no good result. It is not responding to any combination of button clicks.
Please advise.
Thank you very much.

The root cause is still under investigation, but the draining of the battery does contribute to that and causes the device to erase some crucial data from its flash memory.

But you can try this to solve the issue like mentioned in here

I appreciate quick reply ScruffR. We tried to reload from another Electron with no success, Error: Device not found. Still dim blue D7. To get my customer up an running I will try to transfer his card to another Electron.
Thank you.