Electron showing up as core? [SOLVED]

Hi - I am trying to set up my electron and add it to a product I’ve created in the console. However, every time I try to set it up (as an Electron), I get the confirmation, and then when I log in, it shows up as Core. That would be fine with me, except I am trying to add it to a new product group, and whenever I do, it won’t accept the Device ID in the console. Instead, it shows an error message:

“Bummer! No devices were added to your product. Please double check the device IDs are correct and try again.”

I’ve tried adding it through the Particle App, CLI, console - each time with the same problem. Also tried unclaiming each time, unclaiming the SIM and restarting, etc. I can see the SIM just fine, but it keeps saying it’s a Core.

Oddly, I think before trying to add it to a product (yesterday) it WAS showing up as an Electron.

Any ideas?

@jeiden @will


@skialta you provide the device ID of the Electron?

Yes, it is:

OK try now. Should be fixed. I went ahead and ensured that the device was seen by our cloud as an Electron, not a Core.

Thank you. We’re a little closer, but I still can’t add it to this product. Here’s what I tried, in this order:

  • verified it was showing up as an electron (on particle app and CLI) - yes
  • attempted to add it to product 2 (#3338) - same error as above
  • removed it and attempted again - same error as before
  • with it still removed, i tried to add it to my other product, #3334 - it worked
  • removed it from that product - successfully removed
  • attempted to add it to product again - same error

What do you think? I can’t see any reason why it wouldn’t add, but it rejects so quickly I almost wonder if it’s happening client side. However I tried it in another browser, no go.

Followup 1:
Also - now I’ve added it back in, and it’s showing up as a Core again. Strange.

Followup 2:
On closer inspection, I think that your backend platform really thinks this device is a Core, and that’s why it can’t be added. I looked at the setup process for a new product, and I see it asks for the device type, and then after it’s complete, in the header, the product says “Electron.” This theory would explain why I could add it under Product 1, The G-Track, but not under Product 2, “Electron Tracking.”

Screenshot of particle identify:

Is your product 3338 an Electron product?

You cannot mix and match different platforms under one poduct ID.
You need to have one ID for e.g. Photons only and another for Electrons only.

By adding a device ID to an incompatible product, you try to convince the cloud that its current understanding what the device ID stands for is wrong and hence it’ll get all upset and confused :wink:

1 Like

Ah yes, I bet what is happening is that you are mistakenly adding the device to a Core-based product. Then, when you remove it from, our back-end tells the database to revert it back to a Core. Double check you are trying to add the device to an Electron-based product

@ScruffR and @jeiden: I have created two products. One is for Core products (3334) and the other for Electron products (3338). I am not trying to add different devices to the wrong products. I am trying to add cores to 3334 and electrons to 3338. I never tried to add the Electron to the Core-based product until adding to the Electron-based product failed.

However, you said “it’ll get all upset and confused” which it most definitely has. How do I get the Cloud to stop thinking this is a core, and to recognize it has an Electron? Yesterday @jeiden said he designated it back to an Electron, which is correct, it did show up in my device list as an Electron. But then once I tried to add it to my electron product, it rejected it (as described above in my bullet points from yesterday. And now the Cloud thinks it’s a core again.


@scruffr @jeiden Any thoughts gents? At this point, I don’t really know what to do with this Electron. I can’t add it to my product. I’d love to use it if I can, but it seems like I don’t have the power to make the necessary changes. Thanks in advance. - Greg

Another update here: I removed the devices from products and unclaimed the devices. I created a new account, and new products, and attempted to add this electron to an electron product. Same problem. So here’s my current thinking:

  1. I clearly don’t have the ability to reassign this Device ID and have it persist as an Electron. So for the sake of argument, let’s assume that I originally added this Electron device to a Core product, even though it’s an Electron. Am I the first person to do this? What is the process to reassociate the Device ID to the correct product type?

  2. I really feel like this is a bug. Unless and until you modify the backend to allow reclassification, I’d suggest simply adding a warning when someone is adding a device to their product, e.g.:
    WARNING: you have designated this product is a “Core” device. If you add a different device, (for example, an Electron), that device will forever be considered a Core and cannot be changed or added to an Electron product. Please confirm that you are adding a “Core” device!!

  3. Even better would be 1) On your backend, have a table that correlates device type to Device ID’s, and reject any attempted submission of the wrong device; 2) Allow the user to edit/modify/update their product settings. I assume that’s in the product development queue.


Can you try one more time to import into your electron product with ID 3338?

I took another look in the database. We actually have 2 objects that we store related to a device, one is the device record itself, and the other is a keys record we use for provisioning/authentication. For some reason, the keys record had incorrectly assigned the device to a Core. I changed both the device and keys record to be Electron based.

I’m very sorry for all of this trouble you’ve been having. For some reason in our provisioning process, sometimes devices get assigned to the wrong type. Clearly this was the case here.

Let me know if you still have problems.



@jeiden this fixed it! I expected as much right when I logged in because it was displaying as an Electron. I added it to the Electron product no problem. Thanks a ton.

I have another device having the same problem. This time it’s a Photon showing up as a Core. (Note: I also have a Photon Internet Button which is correctly showing up as a Photon – so I think this one should show up as Photon). Anyway, its device ID is 3b001d000247353137323334. I can’t add it to the Photon product, only to the Core.

I’ll be careful not to do that again, if in fact that’s what happened.

Thanks again!


This seems odd to me that you are experiencing this with multiple devices in your account. This other device, has it always shown up as a Core? One thing is for certain --> if a device is in a product and gets removed from it, it will return to the device type that the product is based on.

It seems like somehow someway, these devices found their way into your Core-based product. Then they were removed, and the cloud labeled them as a Core. I’m not entirely sure how this would have happened, as the cloud will block imports of devices that are of the wrong device type (you experienced this first-hand).

But, I do have one theory on how this could happen where a device gets added to a product without being officially imported. Were the 2 devices included in this thread: 3b001d000247353137323334 and 3c0042001951343334363036 ever running firmware that included the PRODUCT_ID macro with your core-based product’s ID? That would look like this PRODUCT_ID(3334).

If these devices were running product firmware from this product, and your product configuration was set to “Auto-approve” unrecognized devices, this could have resulted in these devices being added to your Core-based product unintentionally. Then, when you removed them, they were labeled as a Core.

Does this at all sound possible?

I also went ahead and fixed the photon in the DB.

Fantastic. Checked and it looks good. Thank you!

I don’t know. I don’t remember adding them to a product, but I guess at least with the electron it’s possible. Could it be that the back end would accept any device into a product the first time, and at that point classify it as that device? That seems like it could be possible with the Electron. I don’t remember getting any error messages the first time I tried to put a device into a product.

But I don’t know about the Photon. By the time I had gotten tangled up with the Electron, I was being pretty cautious. It sounds like you don’t see this problem very often though, clearly I did something bizarre. I did get into dfu utility a few times in my earnest attempts to reset the device (thinking it might be the firmware informing the backend). And the Core product was the first device I created.

Sorry, I wish I could recall the specifics. Your theory sounds possible. But I’d still check on the possibility that the products will accept any device the first time they are added.

I appreciate your help in any case. Whew! Have a good weekend.