Electron + Particle SIM + U260/U270 confusion in AU = unable to activate

Is there anyone based in Australia who has successfully activated their Particle SIM and got it working with their Electron U270?

I was able to ‘activate’, i.e. give my billing details and be charged the first $2.99, but my Electron SIM starts up in breathing white and slips into Listening Mode. Couldn’t get to the Electron claiming process, since it never connects to the cell towers. I’m in a metropolitan area, so signal strength is not an issue. Went to the dashboard and could see the SIM card added to my account, but couldn’t deactivate/activate it.

Put in my support request to Particle, but haven’t heard from anyone yet. If anyone on the community here could share their experience setting up their Electron in AU, it’d be good to hear from you. Cheers

@chuank, am from Melbourne, Australia.

You will find that the U270 has very poor mobile connectivity, whereas the U260 has excellent performance. No doubt this is your issue.

Cheers @UMD

1 Like

Thanks for the feedback @UMD, I’m in Melbourne AU too.

I swear I double-checked the model number when I ordered late last year – and thought the U270s listed then included Australia in the region, with the U260s targeted only for the Americas. Did this change sometime between last year and now? I was really sure then that the U270s covered AU… now I’m not anymore?!

Could you actually get a connection at all with the U270s? I also tried an Optus data SIM and instead of going into Listening mode the way the Particle SIM does, it loops between green blinks and the white breathing LED.

Hi @corey, pinging you here as this is likely related to the tech support case I raised.

1 Like

I am based in North East Victoria and our Telstra coverage is poor. I ordered u270s but received u260s, when I queried this with particle they advised that they are now recommending this model for Aus.

On my desk I get one bar on my iPhone, but can’t have an effective phone conversation. On the desk the u260 made a successful connection to the cloud.

The u260 makes sense if you are using the particle sim and if they continue to partner with Telstra, the 270 will be more coverage sensitive.

I am guessing the next model electron will use the ublox international module which means this whole problem will go away, in the mean time it’s tiricky!

Thanks @deancs, I might not be going crazy then! I did remember pre-ordering the u270s specifically, as they were then listed as for use with Australia last year. Did Particle switch telco partners for AU?

Particle did not automatically swap my Electrons to u260s on my behalf though.

The frustration is growing – because like what you said, the u270 Electron should work with 900/2100MHz 3G bands, which is what Optus’ 3G network operates on. I popped in an Optus data sim into my u270 Electron, but it wouldn’t connect either – instead of falling back to Listening mode like the Particle SIMs do, the Electron loops between blinking green and pulsing white. For comparison, I get full signal using this same Optus data sim on a USB dongle (the cell tower’s really close, and I’m in the inner suburbs of Melbourne).

The specs below (from ublox) confirms the u270 connects at 3G on the 900/2100MHz bands:

So now I am truly, utterly confused. :confounded:

The optimum scenario is for me to use the Particle SIM with the Electrons, but my u270s won’t work in AU. However, my pre-order for the Electrons was in December last year, and I recall that the u270 was the recommended model then (and I suppose @deancs’ comment corroborates this?). Or did I really make a huge mistake then?

Also, if based on the u270 Electron’s support for 900/2100MHz 3G bands, why can’t an Optus data sim work then, especially if Optus’ 3G network are on the 900/2100 bands? (edit: setup.particle.io allows Electron setup using non-Particle SIMs, although this is not exactly advertised – just enter your own SIM’s ICCID)

Any other Aussie folks here who might have tried u270/u260 Electrons with Particle/other data sims?

Your not going crazy, particle were definitely recommending u270 for Aus.

I can understand the frustration. I am not sure if you need to change some other parameters to use a non particle sim, I thought I read that somewhere on the forum but cant find the post.

wrt the particle sim, I guess you need to confirm what frequency you receive telstra on, from what I understand some areas are 850 only and some both 850/2100. If you are in a telstra 850 only area then the u270 will not work. The Telstra offical statement for network compatibility is the device must support 850Mhz.

Kevin at particle support was super helpful, I suggest you email hello@particle.io if you havent already done so.

1 Like

Thanks for the heads up, I missed that bit regarding the APN setting. I’ll try what’s discussed in this post to set the APN details for my Optus SIM:

Sending another email to hello and see if this u260/u270 case for earlier au adopters can be looked into with this new information. Thanks again for chipping in!

Ok I found the page where the U270 was suggested in the Support docs as compatible with Australia:

So I tried to setup my Electron using setup.particle.io, and entered a non-Particle ICCID, which led me nicely to the ‘Non-Particle SIM Card’ page that allows me to set a custom APN and compile+download a basic Tinker firmware that I expect will at least allow my Electron to connect to the Particle cloud.

After filling the APN text field (Optus uses ‘connect’) I tried clicking on the DOWNLOAD button – nothing happens, no download started. A quick check on the browser’s JS console shows this:

Anyone getting this same issue as well?

This post suggests there may be an issue with firefox in th non particle sim setup Can't download the 3rd party SIM binary for Electron

Have you tried the custom setup using chrome ?

Judging from the screenshot of the JS Console I can tell @chuank is using Chrome, I’m using it as well, and I can’t get to download the APN firmware. There is appareanty a problem with the baseApiUrl variable, if you see the same screenshot the api url is https://api.particle.i/v1/binaries and I think should be https://api.particle.io/v1/binaries.

Is there a way to access a general APN firmware and manually modify the APN settings?

I tried Chrome, Safari, and Firefox. No luck.

As @Finder discovered from @deancs’ linked post, and as with @jugripa’s eagle eye, there’s a typo in the baseApiUrl variable.

Looks like we’ll have to build the Electron firmware locally to set custom APNs until their setup.particle.io js gets fixed.

Ok, just tested this and local compiling works if you want to get a custom APN/credentials set for a non-Particle SIM on the Electron.

Here’s what I did to upload a modified Tinker app:

First mkdir+chdir to a working folder location where the local electron compiler is to be stored first. Then:

git clone https://github.com/spark/firmware.git particle-firmware-electron
cd particle-firmware-electron
git checkout prereleases/electron-v0.4.8-rc.6
cd user/applications/tinker
nano application.cpp

add this somewhere to the top of application.cpp – I placed it after the includes (edit: added #include which was left out previously):

#include "cellular_hal.h"
STARTUP(cellular_credentials_set("connect", "", "", NULL));

Save the file. Note: the apn “connect” I used is for Optus in Australia, which operates on 900/2100MHz bands and therefore works with the u270 in Australia. Then, set your Electron to DFU mode, and:

cd ../../../main  (i.e. to the working-folder-root/main folder)
sudo -E make clean all APP=tinker PLATFORM=electron program-dfu

Using this method, I got my u270 Electron connected to the Particle Cloud in Australia, with a non-Particle SIM from Optus operating on the 900/2100MHz bands.

Still doesn’t address the original issue of u260 Electrons being the now-compatible ones for Australia, especially if you want to use Particle SIMs here. But I have reason to be slightly happier that my u270s are no longer non-workable.

1 Like

@chuank, @deanc is correct.: U260 is now the recommended model for Australia.

You can also cloud compile, and program your electron locally without installing the local toolchain:

It should, did you include #include "cellular_hal.h" ?

Thanks @BDub, I missed the include for cellular_hal.h, Adding that works now, when using build.particle.io.

@UMD: I’m hoping this u270/u260 swap for AU users can be righted by Particle, especially those of us who pre-ordered when the u270s were first recommended for the region.

I don’t feel like getting Optus SIMs just to get these to work here. One Particle SIM has already been activated, and I can’t deactivate it for some reason… :frowning: anyone with experience on deactivating the Particle SIM service?

Hey all,

I wanted to jump in to provide a quick clarification about the U260 / U270 confusion in Australia.

Based on an outdated reference sheet from our carrier, we were recommending the U270 for Australia. Further research revealed, however, that although Telstra supports both 850MHz (U260) and 2100MHz (U270) bands, they are only actively investing in their 850 MHz network. We sent our beta testers new hardware, and they confirmed that coverage with the U260 was significantly superior.

For this reason, we actively chose to change our recommendation from the U270 to the U260 for all Australian customers and switched their rewards. In the midst of Kickstarter fulfillment, a ball was dropped, and we failed to communicate the rationale behind this change to you all.

@chuank, the documentation you referenced has been corrected, and will update the title of the Electron Kit on our store to more clearly advise the U260 for Australian customers:

Electron 3G Kit (Americas/Aus)

We’d be happy to swap your Electron since we failed to clearly communicate the change and you pre-ordered based on our original recommendation. Please send us an email through our Customer Support Portal and reference this post in your message.

Regarding you SIM card…until you’ve used 20kb of data (which is included for free in addition to your 1MB plan upon first time activation), your SIM will remain in Test Mode and we’re unable to deactivate it within our carrier’s SIM management system. I’ve passed a note of feedback on to our development team to improve the clarity of the error reporting in this scenario.


Thanks @will, it’s wonderful to know that this will be addressed, and I appreciate the offer for the swap. I’ll be in touch via the support portal.

Good to know about the SIM card’s 20kb data, too. That explains the deactivation error – since I’ve never been able to get a U270 Electron connected via the Particle SIM here in AU. I don’t suppose there’s a way to remove my billing information for now?

@chuank please include that in your ticket, and we’ll make sure it gets taken care of as well.

1 Like