Electron driver not working after update

Hello.

I was trying to update my application on an Electron, with a minor error corrected from the previous version. As I was using a new laptop I have downloaded the last version of the drivers, installed them and flashed my Electron apparently without problems. After flashig, the electron has connected to the network as suposed but then it has started breathing magenta, which is not suposed to happen in my application that starts in manual mode. As I have thought that it is due to a firmware update, I have updated the firmware myself using CLI and again, it has been flashed apparently ok. But now the electron driver (windows) is not loaded properly and CLI says there is no device connected via serial. I have reinstalled the driver, restarted the computer several times, to the same result.

As a hint, previous to the update Windows showed the device as Electron Serial -or Serial Electron, I don’t remember. And after the update it appears as Electron and the driver is not working.

Any idea of what is happening here?
Thank you for your help.
Germán.

Breathing magenta means that you tried to flash some application firmware that was targeted for a higher system version than you have got on your device.

You should get the latest CLI and do

particle update

and check what system version you got on it after that.

Since you talk about Particle drivers on Windows - what Windows version?
And what do you see in Device Manager?

Hello.

I have updated it again using particle update, but no version is shown after that, just informs that the update was succesful. Then my Electron restarts, breaths green to get network connection and starts flashing cyan very fast.

I use the last version of CLI downloaded today, on windows 8. Device manager names the device as Electron in the group Other Devices. USB Hardware Id is 2B04 for vendor and C00A for product. Revision is 0200.

To get the version of an Electron you’d do particle identify (but without serial that might get tricky ;-))
But you could go to https://console.particle.io/logs and then put the device in Safe Mode. This should publish an event that tells you about the system state.

If there are any red bursts in between, you may want to perform this in DFU Mode

particle keys server
particle keys doctor <yourDeviceID>

I hope this is Windows 8.1 not 8 :wink:

You may also want to look in this thread

It is done. In safe mode the log gives strange sequences of text data. I am copying them…

I have these three logs, in screen vertical order that I think it is inverse time order.

{"data":"{\"f\":[],\"v\":{},\"p\":10,\"imei\":\"353161071075116\",\"iccid\":\"8934076500002690873\",\"m\":[{\"s\":16384,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"b\",\"n\":\"0\",\"v\":6,\"d\":[]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"s\",\"n\":\"1\",\"v\":21,\"d\":[]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"s\",\"n\":\"2\",\"v\":21,\"d\":[{\"f\":\"s\",\"n\":\"1\",\"v\":21,\"_\":\"\"}]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"s\",\"n\":\"3\",\"v\":101,\"d\":[]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":26,\"u\":\"DD2E81C5C8330C7642B454CCA6C74E65632F06B7C2EF5C450A77683BCC578108\",\"f\":\"u\",\"n\":\"1\",\"v\":4,\"d\":[{\"f\":\"s\",\"n\":\"2\",\"v\":105,\"_\":\"\"}]},{\"s\":131072,\"l\":\"f\",\"vc\":30,\"vv\":0,\"d\":[]}]}","ttl":"60","published_at":"2017-03-09T20:32:58.035Z","coreid":"40003d000c51343334363138","name":"spark/status/safe-mode"}

{"data":"{\"f\":[],\"v\":{},\"p\":10,\"imei\":\"353161071075116\",\"iccid\":\"8934076500002690873\",\"m\":[{\"s\":16384,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"b\",\"n\":\"0\",\"v\":6,\"d\":[]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"s\",\"n\":\"1\",\"v\":21,\"d\":[]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"s\",\"n\":\"2\",\"v\":21,\"d\":[{\"f\":\"s\",\"n\":\"1\",\"v\":21,\"_\":\"\"}]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":30,\"f\":\"s\",\"n\":\"3\",\"v\":101,\"d\":[]},{\"s\":131072,\"l\":\"m\",\"vc\":30,\"vv\":26,\"u\":\"DD2E81C5C8330C7642B454CCA6C74E65632F06B7C2EF5C450A77683BCC578108\",\"f\":\"u\",\"n\":\"1\",\"v\":4,\"d\":[{\"f\":\"s\",\"n\":\"2\",\"v\":105,\"_\":\"\"}]},{\"s\":131072,\"l\":\"f\",\"vc\":30,\"vv\":0,\"d\":[]}]}","ttl":"60","published_at":"2017-03-09T20:32:55.292Z","coreid":"40003d000c51343334363138","name":"spark/status/safe-mode"}


{"data":"online","ttl":"60","published_at":"2017-03-09T20:32:54.181Z","coreid":"40003d000c51343334363138","name":"spark/status"}

And yes, it is Windows 8.1, sorry :frowning:

Solved, at least partially. Thank you for your help.

I have used my other computer -which is a bit of a burden, so I prefer to use the laptop- with Windows 10 and everything has worked without problems.

I have noticed that in Windows 8.1 CLI version is 1.17 and in Windows 10 is 1.20, using the same installer. It would be nice if the windows 8.1 version is updated :wink:

Again, thank you very much for your quick responses.
Germán.

I noticed after updating a Photon to the latest 0.6.1 firmware that the Photon is now recognized in Particle DEV where on the older firmware the Particle DEV would not recognize the Photon and I was having to use TeraTerm to view that COM port.

There is no distinction between OS versions for the CLI.
1.20.1 is currently the most recent version and available for all OSs and versions thereof.

Just try to download the installer again or try this command

particle update-cli

You may also have more than one versions of CLI installed on your 8.1 machine, but the old one might be first in your PATH.

Before reinstalling, try

npm uninstall -g particle-cli

And then see if you still got a Particle CLI on your system and which version it’ll report.

Many amusing things have happened since my last post:

  • After updating the Electron to 0.6.1 I have been able to flash an application on it using my Windows 8.1 laptop.
  • Following your last indications, I have uninstalled the 1.17 version of the CLI that was the active one -it did not recognize the update-cli command.
  • After this uninstall, and without further installation, I executed particle help again and it was 1.20 version running, as you said. Now everything works to my complete satisfaction.

Again, thank you for your kind help.
Germán.

1 Like

You’re welcome!

Now you may also try particle update-cli which should now be recognised as a valid command.