Electron charging with external (i.e. non-USB) circtuit

Hi All,

I’m working on a project where I’d like to have my electron charge wirelessly. I bought a small Qi receiver and charging pad that should provide 1A of power a 5V. I plugged it in and tested just the charging pad and it’s definitely getting 5V, I added a resistor and LED to the circuit and it seems like it’s completing just fine.

That brings me to trying it with the electron. I’ve so far attached the 5V on the receiver to both Vin and Vusb, but I can’t get the charging light to light up or the battery itself to charge. I’ve been putting it in sleep mode to hopefully charge faster as well to no avail.

Any insight would be great! I’m sure I’m doing something boneheaded.

Did you wire up to Vin and GND?

Yup, should have mentioned that in both cases (when I tried Vin and Vusb,) the ground for the receiver was connected to GND on the electron.

Also I took the voltage at both ends and it was a little under 5V (4.9 or so)

Ah nice. Just wanted to be sure. :slight_smile:

Did you measure and made sure there’s 5v when it’s wired to the electron?

Try detaching the battery and see if the electron powers up when the receiver is near the charging pad.

I’d only connect Vin and GND but not Vusb - there is no point in that as that would only lead via a Schottky diode to Vin again anyway.

Also just measuring the voltage alone might not tell the whole story. How “clean” it the DC on the output? Extra filtering caps may not harm.

Let’s see, just tried the following:

  • Vin and Gnd no battery – No lights light up :frowning:
  • DC output seems clean? Not much variation in voltage or an LED brightness if I plug an LED + resistor across the Vin Gnd

Another update – I tried switching the electron for a photon and it the lights light up verrrry dimly (the charging light and the D7 diode.) I guess that means that there’s not enough power flowing through, which is very disappointing. The receiver is rated for DC5V and 1A (I don’t have my ammeter on hand, but I imagine it will show far less than 1A.)

I wonder, I’m pretty novice at most things EE, I wonder if one of my solders is preventing the full amp of current flowing? What would be the best way to test this?

Thanks for the help!

here’s an image of the wire to Qi receiver joint