Electron Charging?

I got my Electron over the weekend. Awesome! Thank you for a great unboxing experience. I plugged in the battery plugged in the usb, set it up and put on some hello world code on and left it all weekend.

This morning I see that the battery is dead even though I have it plugged into usb. I just assumed that the ubs provided a trickle charge but could not find anything in the documentation to state this. Do I need some code to allow to charge over usb? I did not see anything in the getting started stating that I need some special charging code.

I found another lipo battery and plugged that in and am publishing fuel.getSoC() while the usb is plugged in and it is slowly draining. Am I missing something?

1 Like

The battery should charge when you have the USB plugged in to the Electron.

There is a red LED that lights up when the battery is charging above 50mA and the LED is off when the charging current is below 50mA.

The red LED will flash rapidly if you connect the USB port with no battery connected.

Try a different USB port to see if that makes any difference. The TI chip will read the data lines on USB input so that may be a issue.

Does the red LED light up at all?

Thanks for the quick reply

I have never seen the red LED you speak of. You are not talking about the multi function rgb are you? I can not power without the battery attached. i have tried 5 or 6 different usb ports all the same. I am on firmware 0.4.8-rc.6. Not sure if that makes a difference or not.

For what it is worth when I plug into USB particle serial list does not show the Electron. I have a photon on the same usb hub and that shows up fine. I wonder if I have a bad usb connector.

No the red LED is seperate from the multi color LED your talking about.

Sounds like the Power Management Chip is bad.

I don’t work for Particle but @kennethlimcp should be able to point you in the right direction for getting this taken care of.

Yeah I think you are right. As soon as I pug it into my mac it says “Unplug the device using too much bower to re-enable USB devices”

@kbowerma, do you have a multimeter handy?

It sounds like something is shorting the USB supply… Is there some stuff that you wired up to the electron?

This shouldn’t happen since all units are fully tested working before they are shipped. Of course, sometimes things happen and it will be nice to determine what’s wrong and replace them if it’s faulty. :slight_smile:

1 Like

All I wired was the demo light sensor / led / resistor in the ‘getting started’ but I never used it and took it out after a few minutes.

But you are right. I have a micro usb breakout and it is telling me that vcc and gnd are shorted. Definitely not the case with my other Photons, I just did a sanity check on those. That makes sense now: when I plugged this into one of my powerstrips that had a usb port on it, the blue led on the powerstrip dimmed way down and then went off, and one time when I plugged it into my USB hub a Photon that was also connected to the same hub rebooted.

Did you managed to claim the electron before? If you did, then the electron was working fine. Try removing the battery and all the other circuitry to see if it still causes a short.

Check that chip right behind the USB connector and see if any of the pads are shorted. Look over all the pads and see if you see any small bridges.

It actually still works it just does not charge the battery. I think what is happening is that whatever USB host I plug it into is sensing the short and disabling which is the reason it is work. That is just my guess but here is some results of some tests.

With the electron just sitting on the table (no power) nothing plugged in anywhere and no battery in the jst

  1. I measure and short between the usb micro shroud and gnd [ good that is what we expect ]
  2. I measure a open between the usb mico shroud and Vin on the electron (upper left hand pin) [ good that is what we expect too ]

With the Electron sitting on the table and a usb cable plugged into the micro usb port, and the other side of the cable not plugged into anything and no battery
3. I measure and short between the usb micro shroud and gnd [ good that is what we expect ]
4. I measure 195 Ohms across the usb mirco shroud and Vin [ I don’t think this is right ]

Just to reiterate for all 4 of these measurements the only power supplied was that of the dmm. and for the test 2 and 3 the big end of the usb cable was just sitting on the table. I repeated this same step on a good photon and I measured an open between the usb shroud and Vin pin with the same cable plugged in.

I am actually a little surprised it is working at all. It ran for at least a day before the original battery died and now I have a different battery and I am publishing the fuel.getSoC and I was at 62% and could watch it slowly drop over time.

As RWB suggested I cant see any solder bridges with a magnifying glass.

Do you have a hot air rework tool? You could try to reflow that chip if your careful about it. But the chip may just be bad.

Hey @kbowerma it’s unlikely, but it might also be a defective USB cable. Have you tried a replacement?

Good thought will but I checked several cables including the sparkfun micro usb breakout. @RWB I don’t have a reflow station and the pads on the Electron are super small. I think you would need a microscope to place it. They make the Photon look like dinopads.

I’m all out of suggestions :smiley:

@will can guide you on the next step I’m guessing.

Hey @kbowerma – would you please write into hello@particle.io with your issue and reference this thread? That’s our default route for advanced troubleshooting and/or processing hardware replacements!

1 Like

Will do thanks.

@kbowerma would you please make one more measurement for me?

With all power and cables removed, what does the resistance between VUSB and GND read? It almost sounds like there may be a short here that is causing your USB source to shut down and protect itself.

If there is no short from VIN to GND, you could try powering the Electron from there to see if your battery charges. Just apply 5V to VIN with respect to GND with the battery plugged in.

If I create a fake short from VUSB to GND, I measure 7k ohms from VIN to GND… much higher than your 195. Your reverse protection diode could be shorted as well. With Diode checker mode, try + on VUSB and - on VIN, it should be about 0.19V, and OL (open) in the reverse direction. It’s possible if your VUSB to GND is shorted, when you measured resistance from VIN and to USB Shield (GND), you are measuring the forward diode junction. I can get it to read about 300 ohm if I try my diode checker first, then switch to resistance mode without removing the leads. This must be forward biasing the diode better than with resistance alone, but your meter may be different. The key will be if VUSB to GND is shorted.

Likely the USB connector has a fault, or solder short if so.

Here’s a quick diagram of what the VUSB and VIN power look like… there is a diode between them.

So if you have a short from VUSB to GND, powering from VIN should still work.

Just to be clear, there is no connection from VUSB to STM32F205 as this diagram suggests. Just the 2 data lines from USB go there. I’ll have to add that to the list of things to fix about the electron datasheet.

Thanks BDub I think you got it.

With nothing connected I measure an open between vusb and gnd (good) however if I plug in a USB cable to the Electron and keep the other end unattached I measure a short (bad) even though the big side of the usb cable is not connected to anything.

I put 5V across VIN and GND and it is the first time I have seen the red battery light which is solid. I am sending fuel.getSoC event every 30 seconds and I can see it is up to 3% (from 0.2% when I first booted it up)

To me this tells me that their is a problem with the usb connector, since it only has a problem when it is plugged in. Do you agree?

Thanks

Kyle

Interesting, yeah it does sound like something bad with either the connector or the cable. I’m guessing you tried different cables already though all with the same results?

It’s strange that when you plug it in you get a short… try looking in the connector with a magnifying glass and see if you can spot any pieces of wire, solder or bits of foil floating around in there.

Nice, so at least you can play again! If we can’t resolve what’s wrong with the connector… we can work on getting you a replacement. It would just be nice if there was a piece of a something in the connector you could blow out of there with compressed air and solve the problem.