Electron: Can't turn on when powered through Vin with power supply

Hi everyone!

I ran into a problem with powering the Electron through its Vin and GND ports, and was wondering if I could’ve broken the internal regulator. Here’s the current state my Electron’s in:

  • When powered with its 3.3v battery, the Electron’s RGB led turns on and functions normally
  • When connected to my computer’s USB port, only the Electron’s charge status led turns on
  • The same thing happens when I connect the Electron to an external power source.

I tried adjusting the external power source’s from 3.9 to 12 volts, but I couldn’t get the RGB led to turn on at all. The power source is capable of generating 10 Watts (which is required according to the Particle docs)

I also tried running DFU and resetting the Electron, but those attempts were fruitless. I’m wondering if this is due to a broken internal voltage regulator, or is this some other hardware issue?

Any help is appreciated, thanks so much!

Let me ping someone that might be able to help, @rickkas7 or @ParticleD are you able to assist?

This turned out to be a hardware problem and has been taken care of.

1 Like