Electron: Can't connect to cloud using Twilio Sim


#1

Hi!

I am using an electron (that has sat since the kickstarter) with a Twilio Sim.

My problem is that I don’t get past the blinking cyan state. I have updated the device to what I belive the latest firmware version: 0.7.0 and am using the code that I found here: https://gist.github.com/technobly/fb164a7012c64eed7a775f4f7ba91662

From serial monitoring I believe that I am successfully connecting to the cell tower but not Particle Cloud
0000465893 [system] WARN: Internet available, Cloud not reachable!

I have tried resetting firmware, and the public key reset as mentioned here:https://docs.particle.io/support/troubleshooting/common-issues/electron/

The link at tho bottom of that page goes to a document just for photons and cores, so I’m not sure what else to try. Any help appreciated, I am guessing that there is just some part of my stack that is outdated.


#2

These sims have been blocked. Contact Particle for a free replacement sim.


#3

So you can’t use Elections with third party sims? Or are Twilio sims in particular blocked? Is there a reference article about this?


#4

Just Twillio for some reason.

@will may be able to explain.


#5

Do you mean a Particle-branded Twilio SIM? Some of these were handed out at Signal conferences. Those are not supported anymore.

Or do you have your own Twilio SIM, that you’ve set up and are being billed directly from Twilio for? Those are supported as a 3rd-party SIM.

https://docs.particle.io/faq/particle-devices/electron-3rdparty-sims/electron/

In particular, make sure you’re setting the APN to wireless.twilio.com in your firmware. It looks like your code does that, so it’s not clear why it’s not working; it should work.


#6

Yes – to be explicit, Particle does not block usage of any SIMs from any carriers.

At a conference a couple of years ago, we gave away some Particle-branded Twilio SIMs as a part of a partnership around their new Programmable Wireless product. Because we never rolled them out to production and only a small number of customers (<25) were using them, we decided to migrate those customers with Particle branded Twilio SIMs to our primary SIM platform for easier maintenance.

However, any third party SIM can be configured and used with the Particle platform, including Twilio-branded SIM cards from their Programmable Wireless service.


#7

Thanks for the confirmation.

I am using a Twilio branded, non-Signal sims (though I was at Signal and those were awesome). Like I said from the serial logs it looks like I am getting a connection to the cell network just fine, but I can’t connect to the Particle Cloud, so I agree, my APN stuff seems correct. Any next steps for debugging appreciated!


#8

Is anyone able to get Twilio sims to work with the Electron? I had 3 of them working fine for several months, then suddenly, they stopped. These are regular Twilio SIMS that I had ordered through Twilio.com - I did not set the APN in my app.

They are rapidly flashing cyan, then they flash one red, then back to flashing cyan.

I have tried adding the following to my code and it has not fixed the problem, I am worried that third party sims are no longer supported.

#include "cellular_hal.h"
STARTUP(cellular_credentials_set(“wireless.twilio.com”, “”, “”, NULL));
SYSTEM_MODE(AUTOMATIC);

and in setup() I’ve added:

Particle.keepAlive(120);


#9

Yes, if you want to use a Twilio SIM in an Electron you need to put it in DFU mode (blinking yellow) and execute the command:

particle keys server --host id.udp.particle.io --port 5684

The reason is that there was special support for Twilio SIMs in system firmware, but the servers that support it no longer exist. Until that code is removed, the command above will revert the behavior to be a normal 3rd-party SIM on a per-device basis.

You’ll also probably need to use a 30-second keep-alive.


#10

Thank you! Will give it a go!


#11

That worked!


#12

I wanted to follow up here because something strange has happened. I executed the command on one of my electrons and it works fine now. I have two others that have Twilio SIMs that are in delivery vans, and were on the road so I was unable to perform the same thing on them. However, a couple days ago, they have reconnected to the cloud and have been working ever since. I have not yet made any changes to them.

I will be running the command on both of them when I have them in the lot, just so they’re properly configured, but I wanted to point out that the Twilio sims are (for some reason) working fine now.