Does Particle SDK for .Net work?


So - I was looking for a .net interface to replace the CLI - which is now broken on my (windows 8.1) laptop.

The ‘Community Clients’ page in the docs points me at

So I download it and try to build under VS2013 Pro…

Then I fall at the first hurdle. The readme says install a NuGet package but when I do I get

PM> Install-Package ParticleNET.ParticleSDK -Pre
Attempting to resolve dependency ‘Newtonsoft.Json (≥ 7.0.1)’.
Attempting to resolve dependency ‘Microsoft.Net.Http (≥ 2.2.29)’.
Attempting to resolve dependency ‘Microsoft.Bcl (≥ 1.1.10)’.
Attempting to resolve dependency ‘Microsoft.Bcl.Build (≥ 1.0.14)’.
Installing ‘ParticleNET.ParticleSDK 0.7.9-beta03’.
Successfully installed ‘ParticleNET.ParticleSDK 0.7.9-beta03’.
Adding ‘ParticleNET.ParticleSDK 0.7.9-beta03’ to Particle.
Uninstalling ‘ParticleNET.ParticleSDK 0.7.9-beta03’.
Successfully uninstalled ‘ParticleNET.ParticleSDK 0.7.9-beta03’.
Install failed. Rolling back…
Install-Package : Could not install package ‘ParticleNET.ParticleSDK 0.7.9-beta03’. You are trying to install this package into a project
that targets ‘portable-net45+dnxcore50+win+wpa81+wp80+MonoAndroid10+xamarinios10+MonoTouch10’, but the package does not contain any
assembly references or content files that are compatible with that framework. For more information, contact the package author.
At line:1 char:1

  • Install-Package ParticleNET.ParticleSDK -Pre
  •   + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
      + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

and 160 build errors :-O.

Anyone managed to get this built ???.

Don’t even know if its likely to do what I need anyway :open_mouth:

Thanks hopefully…

Disregarding the .Net question (since I’ve got no experience with that), how exactly is the CLI ‘broken’? We can probably help you get it working again if you’re up for it.

Yup I’m up for it, not much time right now - as I am about to be called for dinner ;-)), but will be back to it again in a few hours… (on UK time ;-).

Problem stems (I suspect) from having to replace a Com3 driver a couple of weeks back - after previously installing CLI trashed the FTDI driver which was already installed on there. Had to do this when my 3D printer refused to work again (used Com3). Its a Python app :open_mouth:

Now I ran npm update etc. earlier today and it failed - big time.

Tried to install again and that also fails - so I am left with no CLI…

Node js reports as 0.12.7 - which is as it always was - and working.

My best guess is that I have to go right back and stomp on the serial driver again - although WHY - I can’t understand - as I can talk quite happily to my photon - now on Com5 from ‘RealTerm’ (a serial app) - AND from the CLI (or I could earlier :).

Any help is of course MUCH appreciated as this process is ‘complex’ ???.

Windows 8.1 64 bit.