Disabled Cellular?

I have a Particle Boron. I uploaded a project from Github.

During compiling, I received an error for
…/wiring/inc/spark_wiring_system.h:419:28: in argument to unary !
visitation-counters.ino:827:20: ‘class spark::CellularClass’ has no member named ‘isOff’

So, being the genius I am… I tried to comment out the command,
waitFor(Cellular.isOff, 30000);

This seemed to work and flash to the device, but I seem to now not be able to connect back to my Boron board, even by uploading the simple blink code. I am wondering if I turned off my cellular without being able to turn it on. Can I verify this? If I did do this, is there a way to recover by connecting directly to the device?

Double check the device OS version you got on your Boron.
Cellular.isOff() was only recently introduced in 2.1.0.

Have you tried Safe Mode?

1 Like

Thanks I need to upgrade to 2.1.0.

I have been attempting to enter Safe Mode, but I only seem to be able to put it into listening mode (center light blinking blue, solid blue near usb). I will continue to try to get it to safe mode. I can connect via usb and the CLI. It would not let me flash software and gave a ‘permission denied’ error.

I managed to get it back to working by running through the USB setup → How Can I Set Up My Argon Or Boron Via USB? – Particle Support