Digital pin nightmare

Hi -

Has anyone else experienced problems with D0 and D7 on Photons in particular? I have had 2 out of 5 Photons start up with D7 onboard LED permanently on and unable to get anything from D0. The rest of the D-pins seems to function properly. No matter whether I exclude D7 from code, Include and set to LOW, it remains on.

The problem starts after setting up Photon on WiFi. I of course tried with simple code switching LED’s on/of.

Many thanks!


Do you have anything connected to the photon?

1 Like

Hi @Mjones

Well, only PSU (either via USB) or VIIN and then a single LED connected to D0.

Even with removing the LED, D7 LED still remains on :exploding_head:

Many Thanks.

Is the D7 LED on full brightness or dim blue as in these topics

HI @ScruffR

Hard to tell really as I have never paid much attention to D7 LED . Most certainly not “very dim”. I will try to flash them in DFU mode and see what happens. It also seems to loose connectivity to Wifi, flashing Green intermittently before breathing Cyan again.

Also, when connecting external LED to pins D0 and D7 even with an empty sketch, the external LED’s light up. Faulty boards?


If you have a working Photon you could try pinMode(D7, OUTPUT); digitalWrite(D7, HIGH); to see full brighness and with pinMode(D7, INPUT_PULLUP); (or press/holding RESET)` should give you dimmed brighness.

I have a whole bunch of Xenon’s, Argon and then the two Photon’s I got for a project. If there Reset button option is anything to go by, then it is dimmed as I cannot see and difference. The sketch for pulling D7 HIGH or LOW does not have any effect on the brightness of the LED either.

Further two this, did a particle flash --usb tinker as per one of the post, it said successful yet the D7 remains on. I also tried particle doctor. It seems to go through the process but right at the end give an error saying the doctor app could not be flashed to the Photon.

Have you tried loading a specific Device OS and bootloader via CLI? Then tinker and see if that cures it. If it doesn’t then it is possible that there is a problem with the pin on the photon.

@armor -

No luck… Seems like faulty boards then :confused: