Difference between Boron v1.00 and v1.10

I have three Borons, two v1.10 and one v1.00.
Using the instructions on this page https://community.particle.io/t/boron-3g-lte-europe/46048, and especially this useful project https://github.com/beachviking/particle-electron-r410m-toolbox, I was able to establish successful cloud communication with the two v1.10 models, but not with one v1.00.
As model v1.00 had modem firmware version SARA-R410M-02B-01-L0.0.00.00.05.06 and model v1.10 version SARA-R410M-02B-01-L0.0.00.00.05.08, I decided to update the firmware using these instructions https://community.particle.io/t/ublox-modem-firmware-update/50205/6.
From ublox I got version SARA-R410M-02B-03-L0.0.00.00.05.12_A2.19 so I tryed with it.
Boron v1.00 immediately worked very well, so I decided to update the firmware to two borons v1.10 as well. I successfully updated the modem firmware, but after that I was no longer able to establish a network connection. I also fail to maintain stable communication with the modem to restore the previous version of the firmware.
I tried with different versions of the system-part1, softdevice, bootloader and nothing helps.

Is there any hardware difference between v1.10 and v1.00 that is the reason for this?

Hi @Gurije - how are you finding information about v1.00 vs v1.10? Are you talking about Device OS (Particle · GitHub)?

Hi @marekparticle
On the bottom side of the board is small marking (in red square on the picture)


Some borons have v1.10, other have v1.00.

On https://github.com/particle-iot/boron is possible to find only v1.00.

Hi @Gurije - The silkscreen version number on the board is sometimes useful, sometimes not. On the Boron there have only been two versions, v1.00 and v1.10. The change between v1.00 and v1.10 was for the nRF52840 version D, it should have no impact on the issue you are describing.

It looks like you updated the modem firmware on your device outside of spec and the device cannot connect anymore. I would recommend bringing the device’s modem firmware back to its original firmware version, but I’m not sure whats blocking the device from maintaining said stable communication. Unfortunately, I’m not an expert in manually updating modem firmware (as it’s generally speaking not something we recommend performing yourself outside of specific cases).

1 Like

Thank you for your help. Yes, I did what I shouldn’t have done, but as it helped with one device, I thought everything would work ok with the other two.
With them, it seems that the modem does not respond to the AT + UGPIOC? command, and then connecting process breaks.

To revert to the previous firmware, it is no longer possible to connect to the modem via its usb while the boron is in dfu mode, as I did the first time.
Modem is correctly registered in windows only after the command Cellular.on() (like modem turns on after this command). But this condition does not last long enough to flash the firmware. It seems that the next AT commands throw modem out of that state and again he is properly registered.

Is there any way to just power the modem without sending any at commands and keep it in that status until the flash firmware is finished?

After lot of trying, both borons stared to work normally when I replaced their sim cards. After that, they worked also when I returned the old SIM cards! Is it possible that something happened to the cards that were inside while I was flashing the modem firmware?
In any case, the boron LTE with the latest version of the modem firmware (L0.0.00.00.05.12) works better than it did with version L0.0.00.00.05.08, while with version L0.0.00.00.05.06 I did not manage to connect to the Telenor network at all here in Norway.