DFU util won't write to Boron

Opening DFU capable USB device...
ID 2b04:d00d
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 5336
_dfu-util: Last page at 0x080a14d7 is not writeable
make[2]: *** [program-dfu] Error 74
make[1]: *** [modules/photon/user-part] Error 2
make: *** [flash-user] Error 2
The terminal process "/bin/bash '-c', 'make -f '/home/andrew/.particle/toolchains/buildscripts/1.9.2/Makefile' flash-user -s'" terminated with exit code: 2.

I’m not quite sure what I did to get to this point. Trying to flash just the application or both deviceOS and application gives me the same error.

I then tried flashing Tinker as a test, and the command “particle flash --usb tinker” reports Flash Success, but it doesn’t actually load Tinker on the device.

Does this not make you wonder

When you are building for Photon don’t be surprised when that doesn’t stick on a Boron :wink:

2 Likes

><

Thanks!

In case you tried the -force switch to hammer the incompatible FW into the device you may need to use particle update -v to get the device back into a sane state. This will also set the device OS version to 1.5.2 if you weren’t on that already.

1 Like