Photon with Dim blue D7

One of my prototype board which has an SMD photon on it has a dim blue D7 constantly. I can get to dfu custom firmware but D7 remains dim blue. I cannot do OTA flashes and particle update reboots device into dfu.

How do I fix this?

If device can get to dfu, you could try to upload tinker firmware through cli. And after that, reflash your app. Maybe this fixes the problem.

This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 3952
Download        [=========================] 100%         3952 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!

Flash success!

Does that and then remains in dfu mode

With these outputs always quote the command that created that output too - don’t make us guess :wink:

Sorry about that.

That’s what i entered.

particle flash --usb tinker

Have you tried reflashing the system firmware?

i tried particle update

I get the same problem. I get:
"Error writing firmware…dfu-util: Invalid DFU suffix signature"
when I run this command in DFU mode and D7 is dim blue constantly.
Please help!

I had some luck flashing a monolithic build using dfu. I got it too boot and function but dim blue remains. I cannot update using OTA. It reverts back to dfu on reboot.

I wonder if any of the others can suggest something else.

I managed to fix this

Get the system parts from the releases page on github

dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D system-part1-0.6.2-rc.1-photon.bin
dfu-util -d 2b04:d008 -a 0 -s 0x8020000 -D system-part1-0.6.2-rc.1-p1.bin