DFU mode and device not found

I have put my Photon into DFU mode but the dfu utils says they can not find a dfu device.

When i put the Photon into DFU mode windows saying “USB device not recognized”, how do i install som drivers for this?

Running Windows 8.1 64-bit.

I something doing i getting red error leds when i starting it so i whant to factory reset it but with the buttons i never gets to white led for reset it so i tested DFU mode and got this problem.

Some ideas?

I had this and used this link

Thanks but like i say windows not recognized the usb device.

When i press the message comming up about it its says:

“The last USB device you connected to this computer malfunctioned and windows does not recognize it.”

and in the device manager its says “Unkown USB Deivce (Port Reset Failed)”

That’s what that guide is for, to make your computer recognise the photon. Give it a shot before writing it off prematurely.
Alternatively, have you given safe mode a try yet?
The reason the buttons don’t trigger a factory reset is because there is no factory reset on the photon, as documented.

I have alrady reading the whole guide and its nothing in it thats helps me.

Have you tried uninstalling the device?

yes getting the same result after put it out and in the usb and put it in dfu mode again.

When i triying to get it into safe mode its getting red led blinking.

But you have manually uninstalled it from the device manager, right? Could you try a different USB port and/or cable?

Yes, i have uninstalled it from the device manager, tested with another usb cable in another usb contact on the computer and its comming into device manager the same.

What happens if you go through with the Zadiq driver installed, regardless of the “unknown device” notification? Does that do anything?

I am getting a message saying: “The driver installation failed”

@RickardP, is the device connected to a USB3 port? If so, switch to a USB2 port and test again.

1 Like

I have tested both USB2 and USB3 contacts on the computer and i have tested 3 different usb cabels.

And uninstalled manually on each cable and each usb contact.

And yes i have tested on another computer with windows 8.1, going now test on a windows 10 but i really dont think its being any differents

Edit: WIndows 10 computer same result.

@RickardP, I had similar issues in the past - Windows can be a pain. I ended up doing a few things:

  1. Use a good USB cable
  2. Removed ALL the Core/Photon devices and drivers I had on my system. To do this, I used these command in a small batch file:
echo off
set devmgr_show_nonpresent_devices=1

Once in Device Manager, you need to show hidden devices to reveal all the unconnected devices. Open the “Ports (COM & LPT)” item to see the COM ports assigned to Particle devices. You may also see other drivers setup by Zadig. I then uninstalled all the COM devices associated with Particle devices, including deleting their driver files (check box on the uninstall).

After clearing everything, I rebooted. Then connect you Photon, ideally to a USB2 port, put the Photon in Listening Mode and install the Particle Windows Serial driver for the Photon. Do this by manually selecting the driver (not auto detect). Then, put the Photon into DFU mode and install the Zadig driver for it. Repeat for each device you have.

If after all this Windows dosen’t properly find the Photon on USB then I have no more advice (install Win 10?!).

I have now done that to and getting the same result.

I have like i write in one of the answers tot his post i have tested Windwos 10 and another Windows 8.1 computer.

I really think the hardware has got some wrong.

And this come after have been running without any bigger problem in like one week with a sensor meisure sensor connected.

Then i got internet problem and after that it not have been connected. and when i take it to the computer i see this red led stuff.

Not any help but just an observation.
The device shown in your zadig screenshot does not have a valid VID/PID combination.
For a Photon you should see 2b04:d006
So either the device “forgot” who it is or you’ve got something wrong with the USB link (Photon socket, cable, PC port).

I remember some post where a member had a bent pin inside the USB socket.

can not see anything wrong with the contact.

I have the same problem.

When photon is on DFU, win can’t detect it.

Have you actually tried what’s said further up?

You need zadig and then install the correct driver.
Since your device is already seen as “Photon DFU Mode” USB communication must be working, you just haven’t got the correct drivers installed.

I see you have double posted - which is frowned upon here
[SOLVED]Photon DFU Mode Driver failed for Electron setup
DFU mode and device not found