Device is publishing, but appears offline, with no variables/functions

I have a device in the field that publishes every 30 mins.
It also exposes a variable in the situation where someone wants an instantaneous value (rather than waiting for the periodic publish).

I noticed today, that while I’m still getting values via my publish/webhook, the device appears offline in the iOS app, and in it appears online, but with no functions/variables.

Can anyone thing of why this would happen? Is the only solution to reset the device? (a pain since it’s in the field)

Sharing your code would definitely help to find a solution.

Is this an Electron?
If so the UDP based communication accounts for the lack of valid online/offline information.

Thanks for the interest folks.

It’s a photon, and the uptime and connectivity is typically stellar on this device. It is using Automatic Mode, and System Threads.

The firmware code has gotten pretty large, so I’m not sure what I would share to narrow it down to something relevant.

Strange well what do you know, it’s come back alive all on it’s own… that was almost 14 hours in between! Crazytown :slight_smile:

I am also experiencing this issue with code and a device that was previously working for weeks. I believe particle had an outage yesterday 3/23/2017, but my device is visible but not showing variables or functions when viewing from cloud console or particle list command line. @mdma

I will add my name to this issue. My particle is barely responsive: Takes multiple tries to flash via the cloud, variables take many long minutes to refresh, Particle Console claims the device is going online and immediately online. Just highly erratic behavior for something that was working fine in the past.

It appears I have solved my own problem. I added this line near the beginning of my code:


My understanding is that this lets the system code and application code run in separate threads.

I had been adding numerous Particle.publish() statements along with delay() statements, which
made the overall responsiveness go down the tubes.

Immediate, 100% improvement to all my issues.

Hopes this helps someone.

hah. what do you know. immediately solved my problem. How weird. thanks @alanmalk

I’d like to understand a little better why this started happening out of nowhere though, my firmware’s been running unchanged for some time. Something must have changed.

I’ve got this happening again, but on a different device now. It is in the field, and apparently the wifi router was rebooted at some point during the day (is the only information I have). The device is publishing every half-hour like clock work, but appears offline.

No change in firmware or anything else. Anyone else seen this?