Desktop IDE requires firmware v0.5.3


#1

I’m trying to use the Desktop IDE environment (on a Mac). When I try to verify/compile any code I get an error message stating that the project is only compatible with firmware v5.3.0 or later. The latest firmware version for the Raspberry appears to be 0.5.1-pi.14 (from what the IDE tells me, particle-agent version is 0.2.4).

Is the Desktop IDE currently incompatible with the Raspberry or am I missing something?


#2

I was able to resolve this by using the latest version of Atom instead of the Desktop IDE (which is really just an old version of Atom with the particle-dev-complete package pre-installed).

For a more complete discussion see the following topic:
Revised Desktop IDE?