Deep update not working

So I got out my core, which I haven’t really used much after getting it.
I changed my wifi setup so I did a factory reset (not knowing how to reset wifi settings).
Then I connected the core via the app and everything worked.

Then I saw there was a deep update and did that from the browser.
The update started and the core started blinking magenta.
After a couple of seconds it stoped blinking and only the small blue led was light.

So I waited, but nothing changed. So I decided to do a factory reset and flash the update via usb.
That seemed to work and I booted my core connected it to my wifi.
But after it connects to the cloud it starts flashing magenta and then stops again and becomes unresponsive.

I can then do a factory reset and again connect it to the wifi network, but will get the same result.

Do you guys have any idea what I could do to fix my problem?

Hello there! You do not need to do a factory reset if the OTA deep update doesn’t work.

Simply reset the core and it should be fine.

The OTA might hang but should be able to resume thereafter.

Can you try deep update via the Spark IDE again? Otherwise, we can flash the bin file via USB. :slight_smile:

Hmm that doesn’t seem to work.
Pressing the reset button does not seem to to do anything in this state.

I thought i did the update via usb.
Here is what I did:
-downloaded the bin
-installed the dfu-util via homebrew
-Here a screenshot of the terminal window:

Then after having it connect to the wifi network the process repeated.

So while writing this is wanted to repeat the the update via usb process in order to document it more accurately and that solved the Problem the core now boots, connects to the cloud and works.

Thank you for your help

2 Likes