Core connects to local server but immediately drops it (showing red light)

I have tried the local server, my core can connect the local server which it prints out a line like

Connection from: 192.168.43.44, connId: 64
on ready { coreID: '54ff70066667515129371467',
  ip: '192.168.43.44',
  product_id: 0,
  firmware_version: 7,
  cache_key: '_63' }
Core online!

once the core seems to be online, the core immediately flashes red light, and tried to restart again, the process takes turn, so core constantly connects to the local server, but then immediately drops it. maybe after several minutes, the core prints out another text saying:

1: Core disconnected: socket error Error: read ETIMEDOUT { coreID: ‘54ff70066667515129371467’,
cache_key: ‘_38’,
duration: 617.441 }

how to solve it

Hey @helxsz. When you say “local server,” do you mean that you have set up the local cloud?

yes, I mean the local cloud from the github

Hi @helxsz - what firmware do you have on your Core? You can try flashing tinker to see if that helps:

particle flash --usb tinker

The core should then connect to the local cloud and breathe cyan. Let me know if that resolves the problem, and we can then look at your application to see if there is any issue there.

Thanks, mdma, this works well now.

Great. Then please investigate your application code - the red light indicates some kind of error.

1 Like