Core connected to wifi but can't find it in APP [SOLVED]

Hi all.

Got my core today but wasn’t able to connect with the tinker app (iOS) so did it over USB instead. Now it works fine to flash new software over the internet but I can’t find the core in the app. When I open the app it says “Let’s connect your Core” and my SSID is filled in. I then enters my password but it doesn’t find the core. I have of course searched for a solution but havn’t found one.
Do anyone knows what the problem can be?


I have the same problem, but on Android. The spark updated the firmware and went to breathing cyan, but the app can’t see it. I should note that I have a long password and I’ve seen limitations with that before with other devices (just sayin’)

Thank you for the reply, I hope we find a solution.
For me it takes 1 minute and 19 seconds to flash a program (blink) to the core. Is that normal?

Ikaruz, are you using uFL or onboard antenna? I have had more success with the android app than the iOS app. However, I tend to setup my core’s wifi credentials over USB since it just seems to be less troublesome.

Taking 1min, 19sec may be due to the wifi signal quality. If you move your core closer to the router, does it go faster?

@SandyWalsh, there is a known problem with passwords > 32 characters.

I’m using the core with onboard antenna, and my password is 13 letters. There is no difference in the time it takes to flash if I move the core closer to the router.

I found this

I think I will try it to be able to flash faster :slight_smile:

Ah … my password is < 32 characters, but good to know. Thanks.

Ikaruz, odd! Is your router setup to use a specific wifi channel? Can you find out what channel it is using? How do other wifi devices behave?

Flashing locally is faster for sure. It would still be nice to know why the OTA flash takes so long. :smile:

Ok, some interesting developments.

As I mentioned before, with the app I’d get breathing cyan but no app connectivity. So, I did a manual USB configuration (btw, it would be really handy to have a link to from your main documentation)

(Edit: nm my old comments about blinking green … I entered my password and not my wifi password … doh)

Everything works now. Thanks!

1 Like

Today I tried a third wifi and after a reboot it worked! :smiley:
Sometimes my Apple TV behaves strange so I think my network at home is the problem. Thanks for the replies!

1 Like