Connection to Photon [SOLVED]

i tried, it first show purple/magneta, then it turns into yellow/orange and keep blinking

@leslietsz Yellow/Orange usually means that the SETUP button was being pressed for too long. you want to let go of the SETUP button as soon as you see Purple/magenta

@leslietsz, sorry for all the hoops and loops you must be feeling you need to jump through, but it actually should be easier, when things are done in the correct order.

So the step back and do it bit by bit.
First we have established that your Photon can connect to the cloud (can breathe cyan)
Next, you now know that the Photon has to be in Listening Mode to tell you its DeviceID via USB (CLI or serial terminal)
With this in mind we can proceede and for the sake of reducing the risk of typos, we’ll do things again, even if you’ve already done them.

  1. connect your Photon to your PC via USB
  2. open a command prompt
  3. put your (now cyan breathing) Photon into Listening Mode
  4. go to command prompt and execute particle serial identify
  5. reset your Photon and wait till it breathes cyan again
  6. goto command prompt and type particle device add (with trailing blank)
  7. copy paste the DeviceID (retrieved in step 4) to the end of the line typed in step 6
  8. execute

Then you should end up with

Claiming device <YourDeviceID 24 hex digits>
Successfully claimed device <YourDeviceID 24 hex digits>

Claiming can only be done in cloud connected mode (breathing cyan or magenta)
Serial retrieval of DeviceID only in Listening Mode (blinking blue)

1 Like

i dont quite understand when i tried to connect in CLI, it flashes cyan, but to the last part, it said cannot connect to cloud, so is photon connected or not?

Is it flashing cyan only, or are there other colors as well, like orange?

in CLI , because i need to manually set up the photon, to the last part, it flashes cyan, but it said cannot connect to cloud

Can you make a video of the photon where it’s not working? Explaining colors and patterns over the Internet is apparently not working.

Now i can claim it , but when i run in tinker, it said device not running tinker, and when i click re-flash tinker,it said unable to connect to the server

and it keeps on flashing purple

most updated: finally it works! ,thanks everyone!

1 Like

The flashing magenta was probably a system firmware upgrade that had not yet taken place. Those take a bit longer, but future flashes should now be rather quick. Glad to hear you’ve got it working. If you encounter further troubles, let us know :slight_smile: