Connecting Original (Kickstarter) Spark Cores after 2.5 years

First off, thank you!
I grabbed five spark cores at the initial kickstarter nearly 4 years ago, and used the Core in my final project at uni and aside from a few teething troubles, they worked great.

Now I’ve finally found some time to dust off my Spark Cores and get back into some development in my spare time, but I can’t seem to connect the devices.

I performed a hard reset, waiting until the LED flashed yellow, then white and eventually blinking blue.

Now I’m having all sorts of trouble connecting the devices using the Spark app (yep, definitely using the right app).

The devices still shows on the Spark Tinker app, but when I choose to update the wifi credentials for either Core, or to add a new one, I’m only seeing my home wifi SSID.

I’m sure this has been asked before so I am really sorry if it’s a repeat.

Any help would be most appreciated.

Regards,
Pete

Update 1…

I’m not sure if I’ve ‘solved’ the issue as such, but I did manage to get the Core up and running by connecting over USB (and changing USB cables). Still not too sure why the app route didn’t work though.

Update 2…

So one of the cores shows a solid magenta led after ‘breathing cyan’ for about 1-2 seconds.
The other just flashes green and doesn’t seem to get so far as connecting to the Wifi.

As far as I remember the Cores never exposed an SSID and if your app looks for such, I’m pretty sure this might need to be reconsidered :wink:

You will also want to apply the deep update

Yep, definitely needs a deep update. Please install the Particle CLI and follow these steps

i just today revived one of my old cores which behaved strangely by doing a factory reset followed by the deep-update … fairly easy under ubuntu (dfu-util is a simple apt-get install)

2 Likes