Cloud Server Status

I have been trying to verify and flash via the IDE, but with the following error:
“The server has failed to process the request. Please try again.”

Is the spark cloud server down? If so is there a page to monitor the status?

Hi @BlaBlackSheep - we don’t have a page yet to monitor the Cloud status; we will be putting that together over the next couple of weeks. At the moment, though, we’ve been making a lot of changes to flash/verify via the IDE; try again and let us know if it’s working now.

Hi @BlaBlackSheep , just wanted to let you know that we now have a cloud status page:

Hopefully this is useful and you got your issue sorted out.



i have the problem “server failed to process request on time” now. is that problem at my side or server? URGENT. i have already reset the core and it is breathing cyan, but my code couldnt flash into it.
please help me.
thank you

What is it that you are doing?

OTA flashing of firnware via WEB IDE?

i am trying to flash my code not firmware into the core. the core seems connected to spark cloud already. the LED is breathing cyan but the web IDE gave me the error and my core is still blank.

Hi Ken - Me Too - Issues currently compiling via web ide - taking very long and responds as indicated by @JAlonso
Will save but not compile - I didn’t try to flash. Core operation is AOK

is that server is currently down? when it wll be fixed? my core must work before 1pm 2moro>< i got project presentation to do. please help me

Same problem,
core is on-line and breathing cyan, but web ide times-out and won’t flash core

1 Like

Hello guys, it sounds like the compile server is experiencing some issues and I hope that the Spark team gets notified via their metrics monitoring.

Can you all try to turn off your browser, relaunch and try again?

I noticed this behavior few hours back but did not suspect much. Will drop the team an email right now.

Sorry for the inconvenience!

at least i am not alone. @zach save me please. thanks

Tried that with full log out and log back in…

What I really want to know is why I’m still up … tweaking code!!

hi there, me and my friend facing this problem, and of course all of you too. so i might conclude the server is currently down. hope it back soon.

I just was able to compile and flash! Now - I forgot what changes I made!! LOL!

1 Like

yes its back online and working again.
please tell us all what went wrong…

1 Like

It should self recover usually by metric monitoring.

YESH!!! THX GOD THX SPARK TEAM… it works now <3

@andyg Perhaps sometimes the hamsters on the treadmill that makes it work get tired.

could be - but how do you switch a hamster off and back on again!

1 Like

Looks like there might have been some internal network routing problems at Amazon from 2:55am to 3:35am CDT. Glad it got fixed!