Cloud Compile: Visual Studio Code: Error in particle-cli: ! ENOENT: no such file or directory

I have a problem that just cropped up today (last night everything was compiling, loading, and running fine).
I am using Visual Studio Code with the ParticleIO Workbench
When I Select ‘Cloud Compile’ in the workbench development workflow
-it starts to compile, but then returns the following error in the output window:

Error in particle-cli:
 !   ENOENT: no such file or directory, open 'e:\falco\Documents\ParticleIO\XenonCode_2019_05\XenonCode2019\xenon_firmware_1580851347508.bin'
 !   See C:\Users\falco\AppData\Local\particle\error.log for more info.
Error: Command failed with exit code 1 (Unknown system error -1): c:\Users\falco\.vscode\extensions\particle.particle-vscode-core-1.8.1\src\cli\bin\windows\amd64\particle.exe cloud compile xenon --target 1.4.4 --no-update-check
	at makeError (c:\Users\falco\.vscode\extensions\particle.particle-vscode-core-1.8.1\node_modules\execa\lib\error.js:59:11)
	at handlePromise (c:\Users\falco\.vscode\extensions\particle.particle-vscode-core-1.8.1\node_modules\execa\index.js:112:26)

A couple of other points:
-I did move some of the code blocks around in the program to clean things up
So, could this be an error due to something I messed up in my code?
-When I go to the directory mentioned in the error message,
the file: xenon_firmware_1580851347508.bin is not there
however, there are about a dozen other xenon_fireware files including some dated from last night.

Any help with understanding the above error message and getting me back to compiling would be greatly appreciated.
thanks,
falconm

Could it be that your code just doesn’t build due to code errors?
Usually a mere compile would not be looking for the binary file unless you also want to flash.

Have you had a look at C:\Users\falco\AppData\Local\particle\error.log as suggested by the error message?

ScruffR,
Thanks for the quick reply.
I am assuming I would see some other errors if the code didn’t compile, but I don’t see any additional errors.
I did look at the log, but it didn’t provide me much insight. Here is a copy of the last handful of lines from the log:

2020/02/04 12:59:27 Time since last update 1h46m20.6618272s, update in background
2020/02/04 13:08:35 Time since last update 1h55m29.0678742s, update in block
2020/02/04 13:08:37 Time since last update 1h55m30.388626s, update in background
2020/02/04 13:08:57 Time since last update 1h55m50.6360149s, update in block
2020/02/04 13:08:58 Time since last update 1h55m52.0392727s, update in background
2020/02/04 13:09:52 Time since last update 1h56m45.7440629s, update in block
2020/02/04 21:10:03 Error: ENOENT: no such file or directory, open 'e:\falco\Documents\ParticleIO\XenonCode_2019_05\XenonCode2019\xenon_firmware_1580850594679.bin'
2020/02/04 13:10:03 Time since last update 1h56m56.6364901s, update in background

Can you try a cloud build via CLI from your OS command line?
Maybe that provides more insight.

A couple of other puzzle pieces:
-I have closed everything and rebooted the system, no luck same issue continues.
-tried removing and reinstalling the toolchain (via the Particle Workbench Development Workflow)
-tried “configure the device” to use one of the older deviceOS versions, no luck
-just tried cloud compiling two of my older workspaces (one Xenon code, the other Argon code). Both attempts resulted in the same type of ENOMET error.

I will try your suggestion to attempt the cloud build via CLI from OS command line this evening (I need to read up on how to perform that task).

You just need to cd into the directory where your project.properties file lives and from there run

particle compile xenon .

Just gave the particle compile xenon a try.
I saw:

Compiling code for xenon

Including:
    then a long list of library files
    the src code
   project.properties
attempting to compile firmware
downloading binary from: /v1/binaries/5e3a0a0d7222470001b79370
saving to: xenon_firmware_1580861956178.bin
! Error in particle-cli:
! ENOENT: no such file or directory, open 'E:falco\documents......\xenon_firmware_1580861956178.bin
! See C:\Users\....\error.log for more info.

Interesting that the same error occurs, however, it is now showing that it tried to download and save to the file (xenon_firmware_1580861956178.bin) that it can’t find later.
I did run a search for: xenon_firmware_1580861956178.bin on my entire system in case it was being saved somewhere else, but didn’t find it.

Any thoughts on why the xenon_firmware file is failing to be created?