[Closed]Green LED on use of SPI1

The problem is very simple:

I got a brand new photon and had SPI1 working (which i need for my project). A couple days later i tried the liquid crystal SPI library available on particle build. Since i tried that library(which doesn’t work anymore btw), my photon blinks its LED green approx 5 seconds after the SPI1.transfer (NOT begin) function is called. I’ve read around the forums a bit and this seems to be the sorta duration after which the photon loses wifi if its code blocked. The same code i ran before doesn’t work now. Also this doesn’t happen with SPI, just SPI1. Any thoughts? Could this be a hardware issue or something to do with the firmware? The liquid crystal library uses SPI. Also if i remember correctly SPI1 worked briefly after i tried the library.

EDIT:So i tried just a simple bit of code and it worked in particle build. Ill just try and see if its a problem on my side and come back here if it isn’t. Thanks again o/

EDIT2: Figured it out for now :stuck_out_tongue: