Can't see the device on my mac for serial communication [SOLVED]

I’ve written and flashed the following sketch in the web IDE:

int LED = D7;
void setup() {
    pinMode(LED, OUTPUT);
    Serial.begin(9600);
    Serial.println("started!");
}

void loop() {
    Serial.println("Working!");
    digitalWrite(LED, HIGH);
    delay(250);
    digitalWrite(LED, LOW);
    delay(250);
}

My core is connected via the provided USB cable to my late 2008 aluminum macbook, running OSX 10.9.
After the sketch was flashed and I got the dimming cyan light and the built in LED flashed, I disconnected the USB cable, waited a few seconds and connected it again.

After the dimming cyan light started and the built in LED started flashing, I did ls -la /dev/tty.* but I couldn’t see the core. Same for ls -la /dev/cu.*.
Running ls -latr /dev/tty* doesn’t show a weird /dev/ttyA70cE device neither.

Running sudo dmesg doesn’t show any information about such a core as well.

Connecting an Arduino UNO with a similar sketch (led was 13, not 7) works fine, and I can see that device when ls -la /dev/tty.* and cu.*

Am I doing something wrong ?
Anything else I can try ?

I’ve read the following topics, and nothing helped:

2 Likes

I’ve replaced the cable (the one that arrived with the core) with another micro USB cable, and it now works.

So HEADS UP - the cable may be problematic for some of you.

3 Likes

@dorongutman thanks for the heads-up on this and apologies for your troubles! We’re happy to send you a new usb cable in a few weeks when our second manufacturing run in finished - just let us know.

I tried your exact steps my first time out of the box and I thought I was having this problem too. Swapping out the cable fixed it but then I swapped back to the spark cable and it worked too. I think I just needed an extra power cycle. Have you tried your original cable again?

Or possibly the data pins on the spark cable needed a wiggle. I also encountered problems with a similar, simple USB serial setup recently, but wasn’t in the mood for debugging so just used the LED for feedback. This could’ve been the problem too.

I went through three cables.