Can't put Photon in safe mode or flash to it from cloud

After releasing the setup button after it blinks magneta it goes trough the normal startup sequence and never goes to pulsing magneta.

  1. white
  2. blinking green
  3. pulsing cyan

If I flash anything from the cloud it doesn’t upload to the Photon, the old code flashed with “particle flash --usb somecode.bin” is still there. The cloud tells me in the following sequence: “spark/flash/status = started” -> “spark/flash/status = success” and then “spark/device/last_reset = user”.

I’ve tried:

  • npm update -g particle-cli
  • particle update
  • particle flash --usb tinker
  • particle flash --usb someEmptyCode.bin (which is exported and downloaded from the cloud)

I’ve also tried to unclaim and reclaim, connecting to several wifi’s including my iPhones 4G hotspot, and I’ve used the particle doctor…

I thought there might be something wrong with my keys so I did “particle keys server” and got:

Then “particle keys doctor myDeviceId”:

I’ve installed the libUsbK driver with Zadig.

I’m in a really tight schedule here, I would be very grateful if anyone have any tips to resolve this issue. I feel like I’ve tried everything.

@ScruffR Do you have any suggestions? :slight_smile:

@Kev what version of windows are you running? I have win10 with zadig 2.3 with the WinUSB (v6.1.7600.16385) driver installed.

1 Like

@peekay123 Same. Win10 with zadig 2.3 w/ WinUSB (v6.1.7600…).


Turns out the driver for the Photon was replaced with “usbser” at some point so I replaced it back with WinUSB and restarted my computer. In device manager the Photon device shows up under Universal Serial bus-controller instead of Ports (COM and LPT) like it did before I installed the driver, and the particle-cli doesn’t recognize the Photon (can’t tell that a Photon is connected by USB).