Can't program Photon

I am now the proud owner of 6 Photon bricks. I use the particle app on my eye phone. I put the photon into slow blue blink mode and setup with the correct network name and password. BUT… when it gets to the verify ownership part, the status blink fast blue and fast red and telling me that I got the password incorrect IT’S NOT!!!

I just tried one of the 6 and used the “particle” command and upgraded the Photon and then reprogrammed it and it’s working. I’ll try to fix the others with this process tomorrow

Who/what says the password is incorrect? The App, the color pattern?

If it does red+blue simultaneously, that’d make magenta, indicating either safe mode (breathing) or flashing some kind of software (blinking in various speeds). Have you tried letting them sit for a couple of minutes like that?

1 Like

I used cntl-C, cntl-V to set the password on the laptop as well at the Photon. I used both the particle app and the particle program on the laptop. I recovered 2 of 6, but I can’t seem to get to the Particle WiFi network.

I’ve put in years working with the Photon and have several product designs using them, however, I am discouraged by the lack of reliability. I would be open to suggestions concerning moving to an alternate, more dependable platform.

Have you tried manually typing it?

What commands and what was the output?

How? And what are the other 4 doing?

1 Like

Yes, I manually typed it in and tried the particle app on my iPhone and used “particle setup”. All without success on the four.

I recovered 2 of the 6 using “particle update” "particle flash --usb firmware.bin

The 4 still with an issue

  1. Will not go into DFU mode
  2. Will go into DFU mode, but doesn’t connect with network even though it’s using the same AP as several other devices and I can see messages going from Photon to particle.io
  3. Flashing fast red
  4. flashing fast green to flashing slow green to flashing fast blue to flashing fast yellow/red

I was going to go to kickstarter soon and think I already have 20 sets of my devices spoken for (a set uses 4 Photons). At my current rate, that’s about 30 out of 80 failures - about $570. And… I’ve tried to set up a business account several times without success, so I’m still paying $19 each. On one model of my race timer, I replaced the Photon with an ATMel ATTiny85 which appears to be far less prone to failure.

For reviving devices, it’s often best to flash Tinker rather than custom firmware

particle flash --usb tinker

For the devices that won’t go into DFU Mode you can use Listening Mode

particle flash --serial tinker

This sounds like a contradiction.
What messages do you get of that device?

Can you provide videos of the actual sigals? I guess your “fast blue” is actually cyan, so to be sure, we’d need to see.

For #4 you could try this in DFU Mode

particle keys server
particle keys doctor <deviceID>

For the devices that won’t enter DFU Mode, could you provide the output of particle serial inspect (in Listening Mode)?
I’d just assume the bootloader got “corrupted” and may be reflashed via

particle flash --serial bootloader-0.7.0-photon.bin

Which can be downloaded form here

2 Likes

Hey, I really appreciate the reply. YOU RULE!!! I recovered 5 of the 6 Photons I thought were totally dead and the one that remains a brink I believe it was my fault by pressing too hard on the button to put it into DFU mode. In my defense, it was in a very tight enclosure…

2 Likes

What is that one doing? Any visible signs of life?

1 Like